View Single Post
Old 04-23-2011, 11:08 PM   #75
yifanlu
Kindle Dissector
yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.yifanlu can program the VCR without an owner's manual.
 
Posts: 662
Karma: 170717
Join Date: Jul 2010
Device: Amazon Kindle 3
Quote:
Originally Posted by DickeFix View Post
The creation of the update package was successful. However after installation of the package on the DXG the DXG booted only halfway after which "Your Kindle need repair"-error occured. At the right bottom it said "battery". Maybe it is procedures which are related to the battery which are incompatible since the DXG and Kindle 3 have different batteries.

Anyway, fortunately the recovery console worked and the DXG was put back to life with old 2.5.8 firmware. A software restart was necessary to also get the web browser to work again.

Would it be possible to upgrade firmware 2.5.8 with a smaller subset of v 3.1 e.g. only the webbrowser?
Thanks for the tips! I have another tester who is getting the same error as you and I suspect that the cause is the firmware not reading the hardware battery voltage. Unfortunately, there is little I could do apart from blindly guessing at this point. I do not have a K2i or DX to test with, so it is hard to find out exactly what is wrong. Maybe if you (or anyone else) rip a copy of the /sys structure so I can see what the hardware structure is on the new Kindles, it could help a bit. I think doing something like "find /sys > /mnt/us/sys.txt" via SSH/usbNetwork/recovery port I've been scanning eBay for a while now trying to find a cheap broken K2i or DX to test with, but unfortunately, they're all > $40, which is too much. Right now, I know that it works 99% (just a bit of installer gliches) on the K2 US, but that's the only hardware I can test with.

Last edited by yifanlu; 04-24-2011 at 11:31 AM.
yifanlu is offline   Reply With Quote