View Single Post
Old 03-16-2011, 02:48 AM   #38
kranu
I <3 my Kindle
kranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensionskranu can understand the language of future parallel dimensions
 
Posts: 528
Karma: 51332
Join Date: Nov 2010
Location: United States
Device: Kindle 3G + WiFi
Quote:
Originally Posted by kiwidude View Post
It already is, it just hasn't been documented how.

Not knowing how many people might download this plugin when I published it I would rather not have suddenly had Goodreads suspicious of a mass influx of devkey accounts. If I publish the info here its in the public domain and I would rather hold off on that until it becomes necessary. Lets see how things go and if Goodreads start sending me warnings about volumes then I'll revisit it.
I know it's in the Python source code somewhere. I meant that to add a box that appears when somebody presses "Customize Plugin"

As for a sudden influx, that could indeed be problematic. Seeing as this thread has over 1000 views, that gives the potential of about 1000 people signing up at once. =/ Maybe people should start signing up for API's now, so that if it ever happens, GoodReads won't die from a massive server attack.

That way, people can easily do a gradual transition over, rather than a sudden jump.


EDIT:

I seem to be having a problem with the new plugin. Actually, I tried the old one, and it doesn't work anymore either. I have Calibre 0.7.49. I didn't uninstall the old plugin; I used the add a new plugin button to install over it.

calibre, version 0.7.49
ERROR: Unhandled exception: <b>ZipImportError</b>:bad local file header in C:\Users\James Kwan\AppData\Roaming\calibre\plugins\Goodreads Sync.zip

Traceback (most recent call last):
File "C:\Users\Kranu\AppData\Roaming\calibre\plugins\Go odreads Sync.zip\goodreads_sync_code.py", line 3029, in add_or_remove_to_shelf
File "C:\Users\Kranu\AppData\Roaming\calibre\plugins\Go odreads Sync.zip\goodreads_sync_code.py", line 2416, in get_goodreads_books_on_shelf
File "C:\Users\Kranu\AppData\Roaming\calibre\plugins\Go odreads Sync.zip\goodreads_sync_code.py", line 2220, in create_oauth_client
ZipImportError: bad local file header in C:\Users\Kranu\AppData\Roaming\calibre\plugins\Goo dreads Sync.zip

Last edited by kranu; 03-16-2011 at 03:24 AM.
kranu is offline   Reply With Quote