View Single Post
Old 03-11-2011, 05:01 PM   #1
cybmole
Wizard
cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.cybmole ought to be getting tired of karma fortunes by now.
 
Posts: 2,869
Karma: 1163098
Join Date: Sep 2010
Device: Kobo aura HD, Kobo Arc, Kindle Fire HDX 8.9 , Kindle for PC
no indent for 1st para - lost in conversion

there are a coupl eo fways to format an epub so that all paragraphs are indented except for the 1st on each chapter. I had learned how to do it with additional css styling, then I found what seemed a quick n easy route - jsut add a <br> tag to openign line - like so :
Code:
 <h2 class="calibre6" id="calibre_pb_10">Chapter Two</h2>

  <p class="calibre7"><br />
  <span class="bold">M</span>USIC pounded through Lucís ears.
works fine in epub - although calibre7 in this instance has a 1em indent, it is applied to the initial blank line, so the 1st line of actual text appears with no indent.

like this:

Chapter Two

MUSIC pounded through Lucís ears.

( discussed this in sigil forum & we agreed there that the above html code was working as it should)

but when I convert to mobi (default settings), and view the mobi in calibre viewer, or on Kindle, then the indent IS present ???

how come


is this because of how calibre converts or is it due to differences in epub & mobi specs ?
cybmole is offline   Reply With Quote