View Single Post
Old 03-03-2011, 08:19 AM   #3
ldolse
Wizard
ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.ldolse is an accomplished Snipe hunter.
 
Posts: 1,337
Karma: 123455
Join Date: Apr 2009
Location: Malaysia
Device: PRS-650, iPhone
In this case I think you're running afoul of Calibre's default conversion settings - if you're calling ebook-convert from the command line then you need to change all the defaults that could affect you with the appropriate argument.

Calibre defaults to inserting page breaks before all h1 and h2 tags, this is the xpath:
//*[name()='h1' or name()='h2']

I think if you just pass an empty argument that should fix it - I think it's --page-breaks-before='', but double-check the docs.
ldolse is offline   Reply With Quote