View Single Post
Old 01-28-2011, 02:18 PM   #38
nynaevelan
eBook Junkie
nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.nynaevelan ought to be getting tired of karma fortunes by now.
 
nynaevelan's Avatar
 
Posts: 1,509
Karma: 1464018
Join Date: May 2010
Location: USA
Device: Kindle Fire 6 2014, Kindle PW2, Galaxy Note 3
Quote:
Originally Posted by coaver View Post
Wow! This look like it is going to be a wonderful addition to the Calibre Plugins.

I am trying it out and every time I select to create collections it seems to randomly select some authors, tags and series to create the collections by.

I have applied the following tweak that should make the plug in create collections only based on tags and series:




create_kindle_collections = {
"series": "_ ",
"tags": "- "
}




When I try to create collections it does nt seem to work then when I try to manage collections I get this error:

ERROR: ERROR: Unhandled exception: <b>AttributeError</b>:'BookList' object has no attribute 'rebuild_collections'

Traceback (most recent call last):
File "site-packages\calibre\gui2\actions\edit_collections.py" , line 33, in edit_collections
File "site-packages\calibre\gui2\actions\edit_metadata.py", line 405, in edit_device_collections
File "site-packages\calibre\gui2\device.py", line 1137, in upload_collections
File "site-packages\calibre\gui2\device.py", line 339, in upload_collections
AttributeError: 'BookList' object has no attribute 'rebuild_collections'


How do I fix this? What can I send or post that will help you with fixing this problem?
I received that error too, I thought I received it because at the time I was using the Fetch Annotations feature. I uninstalled the plugin using the instructions in the first post and then re-installed it. There must be some conflict between the two because although it works now, the fetch annotations process is much slower than it was before. But I was able to get them both working.
nynaevelan is offline