View Single Post
Old 01-20-2011, 07:45 AM   #6
Manichean
Wizard
Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!
 
Manichean's Avatar
 
Posts: 3,130
Karma: 80520
Join Date: Feb 2008
Location: Germany
Device: Cybook Gen3
I don't know if that is possible. The problem is, I believe, that the source document, judging from the snippet you posted, doesn't seem to be marked up using paragraph tags, but rather "dumb" linebreaks. You could try enabling the preprocessing facility (found in the structure detection part of the conversion settings) and see if Calibre fixes the markup to include paragraph tags. However, I cannot say if that will necessarily occur for every italics tag.
Another, probably better, solution that comes to mind would be using Sigil. Assuming that the italics tags are preserved, as they should be, you could do a search and replace in sigil on the XHTML and add linebreaks (or paragraph tags) before and/or after the italics as you like.
Manichean is offline   Reply With Quote