View Single Post
Old 01-17-2011, 09:16 PM   #2
theducks
Grand Sorcerer
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 15,054
Karma: 5936659
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: Galaxy Tab 2, Astak Pocket Pro, K4NT
Quote:
Originally Posted by VelvetElvis View Post
Converted a .mobi format book to .epub and loaded it to my Sony PRS-300.
Noticed that all apostrophes and quotes have been replaced by question marks.

Take the word "I've"
On the Sony, it's "I?ve". In the Calibre reader, it's "Ive" (no question mark, nor apostrophe)

Downloaded Sigil (which I've never seen before) and looked at the source code. It also shows "Ive"

Tried to read what I could in the help and various forums. Tried re-converting, using various different Input Character Coding options in Calibre. No joy.

My questions are:
- Why does the Sony show question marks while Calibre's reader doesn't?
- How can I fix this?

Sorry if I've missing something obvious, but I've looked all over and can't find the solution on my own.
You typed the quote and Apostrophe found on the keyboard (straight quote).
Those are probably "curly quotes" that are from a different code page.
try setting a code page (AKA input character encoding) when converting:cp1252 is a good start. the box is under Look and feel section on the conversion options that displays when you click "convert"
theducks is offline   Reply With Quote