View Single Post
Old 11-03-2010, 04:31 AM   #51
xptiger
Junior Member
xptiger began at the beginning.
 
Posts: 8
Karma: 10
Join Date: Oct 2010
Location: Vientiane, Laos
Device: Kiddle 3
Quote:
Originally Posted by ooommm View Post
I succeeded changing amazon's SIM card in my kindle dx graphite to my local GSM provider's sim and getting online

this is what I did:
1. changed sim card in kindle
2. commented these lines in /opt/amazon/ebook/config/browser_prefs
#settings.proxy.hostname = fints-g7g.amazon.com
#settings.proxy.portnumber = 80
#settings.proxy.sslportnumber = 80
btw, if you don't want your kindle to be recognized online as mobile device, change browser identification string in the same file to smt like this:
user_agent.base = Mozilla/4.0 (compatible; Linux 2.6.22)
3. changed DNS server's ip addresses to my GSM provider's in /etc/resolv.d/resolf.conf.3
4. changed some settings in /etc/ppp/chat/connect-3 to be compagtible with my GSM provider's settings (dialing number and AT+CGDCONT connection string)
5. rebooted kindle and thats it! internet worked
Mine is kindle 3 and i there is no file /opt/amazon/ebook/config/browser_prefs. i can see the proxy lines in ServerConfig.conf, but i cannot save it after putting a # into the front. it said the file is readOnly. how can we change to read and write please.
Attached Thumbnails
Click image for larger version

Name:	_prefs.png
Views:	237
Size:	17.6 KB
ID:	60572   Click image for larger version

Name:	ServerConfig.png
Views:	239
Size:	14.8 KB
ID:	60573  
xptiger is offline   Reply With Quote