View Single Post
Old 10-17-2010, 01:28 AM   #54
NiLuJe
BLAM!
NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.
 
NiLuJe's Avatar
 
Posts: 4,045
Karma: 4131199
Join Date: Jun 2010
Location: Paris, France
Device: Kindle 2i, 3g, 4, 5w, PW & PW2
@badbob001:

* I seem to remember updating the bundled readme with basic info about the whole private commands shindig...

* You'll have to switch it using passwd from an usb connection, with the K3_WIFI option off. Or run the passwd file through johntheripper. Or don't bother, and use pubkeys auth .

* Never tried with putty (with or without pageant, or whatever putty's ssh agent name is, not sure right now ) on windows, but I did try with putty & ssh-agent on Linux, and it worked. Make sure the authorized_keys file is not messed up, and has UNIX line endings. You shouldn't have to restart neither your Kindle, nor the sshd for this to be taken into account. I tried OpenSSH & dropbear generated keys, but AFAIK puttygen keys should work too. I'd suggest setting up your router with a DHCP rule to always give the same IP to the Kindle's MAC address, that should help with the IP issue, which in turns answers your last query (if there's nothing listening on the ssh port, then usbnet's off, and if it doesn't answer pings, you got the wrong IP, or wifi's off).

* You can, there shouldn't be any issues remaining with the autoboot feature.

* No idea about wifi+usbms, I'm not sure I even tried that more than 30s to see if I didn't mess up anything in the scripts .

* Apparently, yes, the wifi stays somewhat on during suspend. (I suppose that's to be expected, for all the Whispernet sync/auto deliveries stuff to take place properly). It may be in a slightly lower power consumption state, or switched off after a time, or only on for some period of times, I never really looked into that.

Last edited by NiLuJe; 10-17-2010 at 01:36 AM.
NiLuJe is offline   Reply With Quote