View Single Post
Old 10-09-2010, 12:50 PM   #1
cyberdude
Junior Member
cyberdude began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Oct 2010
Device: Kindle 3
Calibre 0.7.22 not starting in openSUSE 11.3

Hi everyone. I'm new to Calibre and am having a problem with getting it to run on my system.

The install went fine but it won't start. This is the output when starting it from the console.
Code:
 calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 19, in <module>
    sys.exit(main())
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 320, in main
    app, opts, args, actions = init_qt(args)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 40, in init_qt
    from calibre.gui2.ui import Main
  File "/usr/lib64/calibre/calibre/gui2/ui.py", line 30, in <module>
    from calibre.gui2.widgets import ProgressIndicator
  File "/usr/lib64/calibre/calibre/gui2/widgets.py", line 26, in <module>
    from calibre.gui2.progress_indicator import ProgressIndicator as _ProgressIndicator
  File "/usr/lib64/calibre/calibre/gui2/progress_indicator/__init__.py", line 14, in <module>
    pi_error)
RuntimeError: Failed to load the Progress Indicator plugin: the sip module implements API v7.0 to v7.1 but the progress_indicator module requires API v8.0
I'd appreciate any help as I don't really understand the Traceback.

I installed Calibre 0.7.22 from a One-click install which is supposed to take care of all dependencies. No errors were thrown during the install so I assume the dependencies are correct and present but there is obviously something wrong.

My system is openSUSE 11.3 running KDE4.4.4.

Any help appreciated.
cyberdude is offline   Reply With Quote