View Single Post
Old 10-29-2007, 08:51 PM   #1
knewbie
Junior Member
knewbie began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Oct 2007
Device: Nokia N95 / Now PRS-505SC
Ubuntu 7.10 90% of libprs500 install...

Hi All,

My PRS505 SC comes tomorrow morning in the post -
missed todays delivery (Edit : I GOT IT ! I GOT IT !)

I'm using ubuntu 7.10 fresh install, up to date and I'm trying to install libprs500.

first part of Installing prs-500 is a breeze (copy and paste instructions for ubuntu 7.10) but running "libprs500_postinstall" gives me an error :

#sudo libprs500_postinstall
Trying to setup udev rules...
/bin/sh: /etc/init.d/hald: not found
Traceback (most recent call last):
File "/usr/bin/libprs500_postinstall", line 8, in <module>
load_entry_point('libprs500==0.4.16', 'console_scripts', 'libprs500_postinstall')()


File "build/bdist.linux-i686/egg/libprs500/linux.py", line 222, in post_install
File "build/bdist.linux-i686/egg/libprs500/linux.py", line 207, in setup_udev_rules
File "/usr/lib/python2.5/subprocess.py", line 461, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '/etc/init.d/hald restart' returned non-zero exit status 127

Trying to find hald gave me :
# locate hald
/var/cache/hald
/usr/sbin/hald

among other things

hald is running :

# ps -A|grep hal
4866 ? 00:00:01 hald
4867 ? 00:00:00 hald-runner
4934 ? 00:00:00 hald-addon-keyb
4936 ? 00:00:00 hald-addon-keyb
4937 ? 00:00:00 hald-addon-keyb
4938 ? 00:00:00 hald-addon-keyb
4956 ? 00:00:00 hald-addon-acpi
5001 ? 00:00:00 hald-addon-stor

To try a shortcut I created a symlink to /etc/init.d/hal called /etc/init.d/hald and libprs500_postinstall then worked a bit until another stop :

# libprs500_postinstall
Trying to setup udev rules...
* Restarting Hardware abstraction layer hald [ OK ]
Setting up bash completion... done
Setting up desktop integration...
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
WARNING: You need PyQt >= 4.3.1 for the GUI to work. You have 4.3

I have PyQt version 4.3-2ubuntu7, python 2.5.1
Do I need to compile PyQt 4.3.1 manually or something ?

If anyone understood my ravings, please help 8)

Last edited by knewbie; 10-30-2007 at 08:13 AM.
knewbie is offline   Reply With Quote