View Single Post
Old 09-10-2010, 11:02 PM   #2
gdaydigger began at the beginning.
Posts: 22
Karma: 10
Join Date: Aug 2010
Device: Sony PRS 600
I've just found this earlier post below but -- and forgive me for being a dunce -- where do I make the amendment? Do I have to cut and paste "ln, fn" somewhere?


If you want to use "Lastname, Firstname" for authors, then you probably also want to change how calibre copies the author names to the author_sort field. If you don't, then you must manually edit author_sort every time you import a new book or change an author's name to avoid sorting by author displaying the list in a very strange order.

You can control how the copy using a calibre 'tweak' that changes how author_sort is generated from author. In the file, change author_sort_copy_method to either copy or comma (see below for more detail). is found in your settings directory, which for me on windows 7 is C:\Users\charles\AppData\Roaming\calibre.

# The algorithm used to copy author to author_sort
# Possible values are:
# invert: use "fn ln" -> "ln, fn" (the original algorithm)
# copy : copy author to author_sort without modification
# comma : use 'copy' if there is a ',' in the name, otherwise use 'invert'
author_sort_copy_method = 'invert'
I use 'copy'.

If the current author_sort fields are not correct, then once you set the tweak you can reset all the author_sort fields in one swoop. First, verify that the author names are all as you want them. Then select the books you want to change, press E to get the bulk metadata editor, check the box "automatically set author sort", and push OK. The author_sort field for all the selected books will be recomputed from the author field according to the value of the tweak.
gdaydigger is offline   Reply With Quote