View Single Post
Old 08-31-2010, 05:37 PM   #5
Iņigo
Guru
Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.Iņigo did not drink the Kool Aid.
 
Posts: 710
Karma: 72743
Join Date: Feb 2008
Location: Here or there
Device: iRex iLiad, in love with iRex DR800S. Also a K4NT. Now a Kobo Aura
Quote:
Originally Posted by bran View Post
Hi All,

I've got the emulator running.

I'm stunned that the the default block device is so small! Its only 256 MiB and already 45% full is it possible to somehow create a larger virtual SD card and use that instead? If that is possible, how do I do that?

What I also noticed is that the SD card that is mounted on first boot in the emulator is an ext2 file system. Does that mean that native linux filesystems are availble for the SD card on a physical DR800 device? Obviously the vfat filesystem is the lowest common denominator, and that it is the one, most computer users are familiar with. So, using vfat makes sense from a consumer's point of view. For me using ext or ext3 or jfs makes more sense. Is this possible?

Regards Bran
qemu doesn't emulate the SD card really, it's using root partition:

Code:
root@qemuarm:~# df /media/mmcblk0p1/
Filesystem           1k-blocks      Used Available Use% Mounted on
rootfs                  275415    211130     62236  77% /

If you look at /etc/fstab file you could see that SD card is mounted with auto parameter as file system type. That means that you should use any file system supported by the kernel:

Code:
root@qemuarm:~# cat /etc/fstab
# stock fstab - you probably want to override this with a machine specific one

rootfs               /                       auto          defaults              1  1
proc                 /proc                proc          defaults              0  0
devpts              /dev/pts           devpts       mode=0620,gid=5	   0  0
usbdevfs          /proc/bus/usb  usbdevfs    noauto                0  0
tmpfs                /var                  tmpfs         defaults              0  0
tmpfs                /media/ram      tmpfs         defaults              0  0

# uncomment this if your device has a SD/MMC/Transflash slot
#/dev/mmcblk0p1       /media/card          auto       defaults,sync,noauto  0  0
... and which are the supported file systems:

Code:
root@qemuarm:~# cat /proc/filesystems
nodev    sysfs
nodev    rootfs
nodev    bdev
nodev    proc
nodev    sockfs
nodev    pipefs
nodev    anon_inodefs
nodev    futexfs
nodev    tmpfs
nodev    inotifyfs
nodev    devpts
              ext2
              cramfs
nodev    ramfs
	      vfat
nodev    nfs
nodev    nfsd
nodev    smbfs
nodev    jffs2
nodev    rpc_pipefs

Ok, I haven't tested it but ext2 should work.

Hope it helps,
Iņigo
Iņigo is offline   Reply With Quote