View Single Post
Old 08-05-2010, 11:33 PM   #5
RCR
Addict
RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.RCR ought to be getting tired of karma fortunes by now.
 
RCR's Avatar
 
Posts: 334
Karma: 992487
Join Date: Dec 2007
Location: Melbourne, Australia
Device: 2 x Sony 505, iPad, Samsung 7 Tablet, ASUS Transformer, Nexus 7
Hi Khronos -

I had the same problem with one pdf. It was a heavily illustrated ebook that showed up fine on my computer. But on my iPad, the illustrations were blank pages.

Mr Google does have the answer. He sent me to

http://forum.rpg.net/showthread.php?t=516459

where they discuss this issue. It's to do with jpeg vs jpeg2000.

On that forum, they also point to the Goodreader faq. Here's a quote from the Goodreader trouble shooting faq:
---------------------------------------
I see blank pages in my PDF file, but it shows fine on my Mac/PC There are two main reasons for this:
JPEG2000 image compression. This compression used in some PDF files can't be understood by current versions of iPhone OS (and GoodReader heavily relies on its capabilities). However, there's a very easy workaround for that.
If you have a Mac computer, open this PDF file in Mac's standard Preview application, go to File menu and select Save As command. Then resave this file as a new PDF (just make sure to change a file name, to preserve the original file unchanged). The new PDF file will be formatted in iPhone-friendly way.
If you have a PC computer, the solution would be to reassemble a file in Adobe Acrobat software (or other) replacing JPEG2000 image compression with more conventional JPEG. Print your file to a special Adobe PDF printer (installed by Acrobat). Make sure that inside this printer's settings, on Images tab two first Compression fields don't show JPEG2000. If they do, change them to JPEG.
-----------------------------------------------

End quote.

What I did with my own troublesome pdf was:

*Launch the pdf using Adobe PDF Reader.
*Go to file/print and select "Adobe PDF" as the printer.
*Go to Properties/Adobe PDF Settings
*In Adobe PDF Output folder, select a location on the computer for the output.

The newly created pdf displayed correctly in iBooks on my iPad.

I'm using Adobe Reader Pro v8 and Adobe Reader v9 on Win XP. I hope this helps with whatever programs you are using.
RCR is offline   Reply With Quote