View Single Post
Old 07-11-2010, 03:23 AM   #1
Junior Member
DaveisTaken began at the beginning.
Posts: 6
Karma: 10
Join Date: Jul 2010
Device: Kobo
Error when syncing with borders software with 1.4?

I get an error on my Mac when trying to sync library with my reader, it says "Your desktop client needs updating. Syncing cannot be completed.".
I paid money for several books and I cannot sync them with my reader, what tha heck!!

How do I fix this?
What version do I need?
I downloaded it from

Last edited by DaveisTaken; 07-11-2010 at 03:24 AM. Reason: Title spelling error...
DaveisTaken is offline   Reply With Quote