View Full Version : Borked 1.5

07-02-2010, 11:52 AM
This is more of a whine than anything else, but if someone else out there has the same problem, there is a fix.

I have an HTC Hero phone that was running Android v1.5. I kept checking for updates, but it kept telling me nothing was out there. I was fine, since it seemed to me that there were the apps that I wanted and it was functional.

Then I tried getting an online formulary that I need for my clinical work and could not find it. The company was crowing about how wonderful they were that they had an Android app at last so I wrote them and said that I couldn't find it. They wrote back and said I needed v1.6. So I tried again to update. Several times. It kept coming back that none was available. I figured that Sprint had not authorized the upgrade for some reason and filed the intent to complain the next time i was by the store.

Then Kindle for Android came out and it would not appear on my phone. FInally, I was at the point that even I in my glorious laziness, would do dome thing. I went to the Sprint website and poked around and found out that ANdroid is now in v2.xx! There were instructions there on how to do the upgrade by computer connection, rather than over the air.

So, I started doing it. There were a lot of warnings about backing up etc, since the memory would be completely erased, so I also downloaded their sync program and ran that. After about half an hour of instal and restart, I was finally able to run v2.xx on my phone and get the apps that I was wanting.

Moral: If you look for a specific app and can't find it, in spite of knowing that it is there, check your Service Provider for the latest version of Android, since it seems to have the ability to get stuck on one version.