View Full Version : hanvon n516 - flashing successful but device doesn't boot


eluna
06-26-2010, 07:40 AM
Hello everyone,

I have a huge problem with my n516. I tried flashing it with the new azbooka usbboot and the old one, also i tried different builds. But the result remains the same, when the flashing is trough, the device doesn't boot after resetting. The ledlight is glowin blue and nothing happens.

What i notice is, that he counts the bad blocks wir azbooka usbboot, but when i hit nprog, he doesn't count them. so i don't know if he consider them in the progress of programming.

Also I tried to put on the old firmware and was close to brigg my n516 :D the erasing took very long and i close the programm, disconnecting it. And aaaaall the lights remain dark, it was dead :D after one day it become alive again and i could connect it to my pc. and yes, i also use the attachment and consider everything here http://openinkpot.org/wiki/Device/N516/FlashOriginalFirmware

hope you can help me, i am a but desperate :D

LG,
eluna

ixthir
07-14-2010, 09:50 AM
Hi there,
same problem for my N516 as well. I tried to install 0.2.1 and the daily release 20100713
Erase works, Flashing works, but when i reset the device after the flashing, it will not boot and the light is glowing blue.

Hope there is someone who can help.

regards
ixthir

mr ploppy
07-16-2010, 12:57 PM
What does it do if you just install 0.2 without the daily release? I'm not sure which upgrade I tried, but I just ended up with lots of lines all over the screen. Deleting it all and starting again with 0.2 fixed it. The later versions are still being tested, so if you just want it for reading stick with what works now.

leidola
07-17-2010, 10:55 AM
Seems as if i had a similar problem.
First of all I tried 0.2.1 for n516. Flashing worked fine (I think) but when resetting the device nothing showed up, the blue light glowed with full intensity.

It took me a while to find out how to get the device into a reflashable state (blue light glowing weakly), but I found out that holding reset and rotate while usb is connected seems to do the trick.

Then I tried 0.3-current. As the original poster I noticed 6 bad blocks where reported after running nerase. Yet, nprog mentioned 0 bad blocks when being run.

I followed strictly the README file.

I noticed the option -o of nprog. Trying this one. But the message cannot connect device appears on every step and it seems to increase the bad block count. Can this be resetted?

leidola
07-17-2010, 11:20 AM
Hmmm... semms not to work anymore. No shiny blue light when pressing reset and no line in linux kernel log about a new usb device when plugging it to two different computers *confused*. Any hint on restoring the device?

Is there maybe a way to get some more information out of the device?

leidola
07-18-2010, 07:18 AM
Okay, I could get the device to a defined state again by opening it up and removing the power supply for a few secs. Now I can reflash it again.
But it seems as if the number of bad blocks was increased drastically by the last nprog attempt.

Please have a loot at http://pastebin.com/kJicpwFx

Flashing with 0.2.1 or head still does not lead to a booting device.

mr ploppy
07-18-2010, 08:26 AM
How do you open it?

leidola
07-18-2010, 08:48 AM
How do you open it?

As described here:
http://openinkpot.org/wiki/Device/N516/Opening

The main problem was getting a torx screw driver :)

leidola
07-19-2010, 10:40 AM
I just learned that I own a newer version of N516 with a bit different hardware(*). It does not work out of the box with oi at the moment. Need to debug what's wrong.

(*): E.g. the display controller has changed. It's an epson controller. You can check it by opening the device.

mr ploppy
07-19-2010, 11:59 AM
If there is more than one version of the N516 that would explain why it doesn't work for some people. I haven't used it, but I have heard that the German version of the firmware is almost as good as OI and can be set to English. If you ask in another forum someone will tell you where to get it from if you can't find it.

leidola
07-19-2010, 12:15 PM
I haven't used it, but I have heard that the German version of the firmware is almost as good as OI and can be set to English.

My device used to have the german version installed, but there were some things I didn't like, e.g. the font style and size when reading txt files. Anyways, I can't reflash the original firmware, as some parameters are probably different, e.g. for nprog. I tried the procedure described on the wiki page and it failed.

So the situation has to be debugged anyways :)

mr ploppy
07-19-2010, 04:08 PM
You can convert txt to epub with Calibre and set your own font size, etc.