View Full Version : How to reduce indents without "removing space between paragraphs"


Skydog
05-30-2010, 09:48 PM
I'm sure there is a simple solution but I have yet to figure out what it is.

How does one change the indent size of a .prc without being forced to select "remove spacing between paragraphs?" I do not want to change spacing anywhere in the document, just reduce the indents.

Thus far, I have been converting .prc => epub, editing the css, then converting epub => .mobi. The problem with this method is that the original .prc contains enlarged font in the first letter of each chapter and this is lost during the above conversion.:(

The original .prc is just fine with the exception of the indent size.

Thank you in advance for your help.

DoctorOhh
05-31-2010, 12:38 AM
How does one change the indent size of a .prc without being forced to select "remove spacing between paragraphs?" I do not want to change spacing anywhere in the document, just reduce the indents.

The original .prc is just fine with the exception of the indent size.

On my reader I set my css for indents. Try adding

p {text-indent:1.1em;}
div {text-indent:1.1em;}

(adjust size to suit) to the Extra CSS area of Calibre prior to conversion.

What I usually do is set both Remove spacing between paragraphs and Insert blank line in my default conversion. This gives me the indent size I want and the space between paragraphs I like.

The blank line is created by adding a .5em margin above and below each paragraph. As you noted though Remove spacing between paragraphs does change spacing throughout the document.

Good Luck.

Skydog
05-31-2010, 01:39 AM
I added the lines to extra CSS prior to conversion but they had no effect whatsoever. I changed indent sizes with three attempts but the result was the same. This while converting from .prc to .mobi.

Additionally, the first letter of each chapter is still being replaced with the same font size as the text, so Calibre must be doing something in the conversion that is beyond my limited knowledge.

Thank you for the suggestion.

theducks
05-31-2010, 10:44 AM
I added the lines to extra CSS prior to conversion but they had no effect whatsoever. I changed indent sizes with three attempts but the result was the same. This while converting from .prc to .mobi.

Additionally, the first letter of each chapter is still being replaced with the same font size as the text, so Calibre must be doing something in the conversion that is beyond my limited knowledge.

Thank you for the suggestion.

Skydog, search in the Sigil section for "dropcap". There are a few ways to do that.

You need to place/adjust the text-indent settings in the proper place(s)
Look at the source-view to see what a normal <p .... starts with (not the Dropcap <p )
That is where the text-indent belongs (I use 1em on my PEz)
remember the continuation (;) on the line above or it will not work

Skydog
06-04-2010, 09:50 PM
Skydog, search in the Sigil section for "dropcap". There are a few ways to do that.

You need to place/adjust the text-indent settings in the proper place(s)
Look at the source-view to see what a normal <p .... starts with (not the Dropcap <p )
That is where the text-indent belongs (I use 1em on my PEz)
remember the continuation (;) on the line above or it will not work

Yes, I have been replacing the text-indent settings by converting twice. Once, converting with debug selected, correcting settings, then converting again. I was hoping there might be a simpler method.

Thanks for the advice regarding the dropcaps.

theducks
06-05-2010, 12:58 AM
Yes, I have been replacing the text-indent settings by converting twice. Once, converting with debug selected, correcting settings, then converting again. I was hoping there might be a simpler method.

Thanks for the advice regarding the dropcaps.
In Sigil, Edit the text_indent: in the proper section of the CSS file.
Save
done