View Full Version : ADE bug in calculating width


DaleDe
01-15-2010, 06:56 PM
I have a book I created (a Bible actually) in ePUB. I defined paragraphs but I wanted all the verses to begin at the start of a line. So for each verse I added a <br /> tag at the end. Some, of course, were longer than a line on the screen. When this happened ADE chopped the last few characters off the right edge of the screen before wrapping the line. I rebuilt it using only paragraphs and it wrapped fine. It seems ADE can't figure out how wide a line is if it is terminated with <br />. This is pretty basic stuff. I was surprised it was broke.

Dale

JSWolf
01-15-2010, 10:56 PM
Is that valid in XML?

DaleDe
01-16-2010, 02:15 AM
Is that valid in XML?

Anything is valid in XML so long as you specify a defined DTD. The question should have been is it valid in XHTML which defines both the XML and the DTD to to interpret it. The answer is yes more certainly <br /> is defined in XHTML which is the file format used in ePUB for eBook content.

Dale

salty-horse
01-16-2010, 01:00 PM
I reported a similar bug to Adobe a month ago, which involves parentheses and <br>.

It looks like this:

http://www2.mta.ac.il/~oravtali/ade-bug.png

<body>
<p>
With opening parentheses<br />
(a long line [...]
</p>
<p>
Without opening parentheses<br />
a long line [...]
</p>
</body>


They already fixed the bug before the report, and it is available in the latest SDK.
Of course, that isn't worth much until Sony and others update their firmware.

DaleDe
01-16-2010, 01:24 PM
I reported a similar bug to Adobe a month ago, which involves parentheses and <br>.

It looks like this:

http://www2.mta.ac.il/~oravtali/ade-bug.png

<body>
<p>
With opening parentheses<br />
(a long line [...]
</p>
<p>
Without opening parentheses<br />
a long line [...]
</p>
</body>


They already fixed the bug before the report, and it is available in the latest SDK.
Of course, that isn't worth much until Sony and others update their firmware.

Thanks, it does look like a similar bug. My lines began with a verse reference that looked like {1:1} but I hadn't realized that the unusual starting character might cause the problem. Thanks for sharing. Hopefully this fix will get propagated soon.

Dale

JSWolf
01-17-2010, 10:04 AM
Can someone post an ePub that shows this bug and I'll try it on a 900 and see if the bug sill exists.

Jellby
01-17-2010, 10:33 AM
I was just preparing a test file to show other features, but thanks to this thread I could hunt down another bug that was bugging me, affecting centering with manual linebreaks.

In my Gen3, the centered heading with parentheses is not properly centered (the last line is more like right-aligned).

Another issue is the very long paragraph has spurious pagebreaks appearing inside it. There's nothing weird in the paragraph, it's just a long one, but it seems the software cannot handle it all at once.