View Full Version : Creator cover not displayed in library view


mtravellerh
11-09-2008, 06:00 AM
Now I created this wonderful collection of Karl May's works that I am really proud of. I even created myself this wonderful leather cover with the western style title imprinted. Looks really good, all my "graphical talent" considered. It's 600X800 jpeg as stipulated by Mobi Creator. It displays mighty fine when opening the book if I dare say so myelf.

Buuut: there is no cover in the icon library viewin PC mobi reader. Nothing. Zilch. Now I am seriously frustrated, (cf Blues reading (http://www.mobileread.com/forums/showthread.php?t=31699)) Any and all help or tip would be greatly appreciated. The book's here (http://www.mobileread.com/forums/showthread.php?t=31697) (the collection).

I checked in the mobipocket forum already and here, but I didn't find any solution.

Cover is attached

AZed
11-09-2008, 12:20 PM
Two things:

First, have you clicked on the cover once in the reader library? Covers aren't actually loaded until the first time they are clicked on.

Second, have you ever had a book with the same filename in the library that *did not* have a cover (i.e. did you ever read that book before you put a cover on it)? Mobipocket Reader has a broken image caching system relying on the .mbp file pointing to a local cache, and the .mbp (and maybe also the cache files) may have to be deleted.

wallcraft
11-09-2008, 01:01 PM
I downloaded Winnetou.prc and the cover shows up in the library view for me.

mtravellerh
11-09-2008, 01:02 PM
Two things:

First, have you clicked on the cover once in the reader library? Covers aren't actually loaded until the first time they are clicked on.

Second, have you ever had a book with the same filename in the library that *did not* have a cover (i.e. did you ever read that book before you put a cover on it)? Mobipocket Reader has a broken image caching system relying on the .mbp file pointing to a local cache, and the .mbp (and maybe also the cache files) may have to be deleted.

Oh yeah. I DID open that book before putting a cover on it, just to test things out. As soon as I am out of bed, and back on my desktop, I will delete the .mbp and see what happens. :thanks:

French
12-29-2008, 10:57 PM
I'm actually having an issue with this myself. But I may be going about this all wrong.

I had a .png file that should be the icon. So I deleted the generic mbp file that was associated with the book. I renamed the generated png icon to bookname.mbp and I placed in the same directory with the book of same name.

But it's not working. My book still has the generic cover.