View Full Version : Mobi2Mobi Mobi2Mobi GUI Cover Art Help?


huskies4all
08-26-2008, 01:49 AM
Hi, I read through the other threads and didn't see anything that gave me a clue. That must mean I'm clueless? :-) I apologize for what I am sure is probably an extremely noobish question.

Why do some of my "ebooks" simply REFUSE to show a cover art picture? I've tried resizing the .jpg down, and I've tried using mobi2mobi GUI on the .prc file from my ebooks directory, and even tried again on the .mobi file that came from that operation, and nothing. When I load the book in Mobi2Mobi GUI, the cover art appears. But it doesn't appear in Mobipocket.

Is this sufficient information to see if someone can help me? If not, what can I look at/tell you more of to see if I can work this out?

tompe
08-26-2008, 03:41 AM
Is this sufficient information to see if someone can help me? If not, what can I look at/tell you more of to see if I can work this out?

Probably not.

An example file were it fails to show for you would probably be enough information.

huskies4all
08-26-2008, 05:57 PM
Ok, for instance, I import my class syllabi to Mobipocket. They are imported from Word documents, and I had wanted to put the instructor's photo as the cover of the book.

I've attached the .mobi file. On my computer,when I open this file in Mobi2Mobi GUI, the cover and thumbnail appear in the appropriate boxes. In Mobipocket, they do not.

CJ

tompe
08-27-2008, 01:39 AM
Which version of MobiPerl did you use?

Running mobi2mobi on the file you get some information and it seems that the coveroffset and thumboffset have strange values or that the images are in strange records. I think the coveroffset should be 41-17 and the thumboffset 42-17 since the images are in record 41 and 42 and images start at recoed 17. But I do not understand why the record numbers are as they are.

Maybe this is an instance of the bugs that pdurrant found and that you should try the binaries with his fixes.

I will do a new release with his fixes in a couple of days...

huskies4all
08-28-2008, 01:03 PM
OK, I'm using Mobiperl Tools 0.0.38. (The windows binaries)

I tried using the exth changing boxes in Mobi2Mobi GUI and changed the coveroffset to 41-17, and the thumnailoffset to 42-17.

1. The output log showed coveroffset 41 and thumbnailoffset 42. The cover art disappeared in Mobi2Mobi GUI
2. I then re-loaded the cover and converted, the cover reappeared in the GUI, and the coveroffset and thumbnailoffset remained at 42 and 41, but the cover still does not show up in Mobipocket.

I am not sure where to find pdurrant's binaries...did some unsuccessful searching...I think I'll wait until you update yours.

huskies4all
08-28-2008, 01:10 PM
Of course I found the binary just as soon as I posted above. Off to see if it helps!


...Edit to say: NO, it still doesn't work, and I eve tried re-importing the file into mobipocket and starting 'fresh'

huskies4all
09-01-2008, 08:02 PM
After a couple of shutdowns, it seems to be working. All 'covers' I have added are now showing up. I don't know what I did differently, but using the 'new' binaries seems to have solved the problem.

Islanti
09-04-2008, 11:31 AM
It may be Mobipocket's fault. It caches the covers and thumbnails. In some cases I had to delete the subfolders under my ebook directory to get it to refresh these.