View Full Version : Adding a cover image to mobipocket files


rheostaticsfan
05-22-2008, 11:38 AM
Hi there,

I have spent the last few weeks learning about conversion tools around here. I had around 60 each of ereader and mobipocket files which I just ran through converting into each other's type.

I have a total of 57 .prc files that have no cover image. I was pretty careful to add cover art when converting .pdb to .prc but it's possible I forgot to click the update button on the cover image option within mobicreator.

Anyhow, I'm hoping that the smart people here can tell me how to add cover art to these mobi files. I tried using mobi2mobi but that didn't work at all. I have version 0.0.38. Mobi2mobi warns me that the image is too large (it's 228 x 340 so I don't understand that warning) and theres many lines of other text most of which is meaningless to me.

So...can anyone help me?

Hadrien
05-22-2008, 12:01 PM
If you create a Mobipocket file using an opf file, you need to add the following lines in the metadata:

<x-metadata>
<EmbeddedCover>cover.png</EmbeddedCover>
</x-metadata>

Not the most user-friendly way to generate a Mobipocket file, but it works.

tompe
05-22-2008, 12:13 PM
Anyhow, I'm hoping that the smart people here can tell me how to add cover art to these mobi files. I tried using mobi2mobi but that didn't work at all. I have version 0.0.38. Mobi2mobi warns me that the image is too large (it's 228 x 340 so I don't understand that warning) and theres many lines of other text most of which is meaningless to me.


What does it say exactly?

I would guess that it says that it can not shrink the image file size to under 60K or something like that. How big is the original image file?

rheostaticsfan
05-22-2008, 12:43 PM
The original file is 42k.

I have attached a print screen of the messages.

I created this .prc by doing mobidedrm...all the text seems to be in one line and I"m having a tough time sorting out how to deal with it.

tompe
05-25-2008, 04:40 PM
The problem is that the cover offset is set totally wrong for some reason. It is hard to say why without having the file.

You can try to change just the coveroffset to something more sensible like 0 or 1 with --coveroffset (just this flag to mobi2mobi).