View Full Version : Touch Extra spacing between paragraphs on my e-books


Aiden
12-10-2013, 10:01 PM
Most of the e-books that I transfer to my Nook Simple Touch get added extra spacing between the paragraphs, but previewing them on Adobe Digital Editions and on Calibre (What I use for transfer) shows no spacing at all. I tried transfering with Calibre and manually, but it makes no difference. This happens with a lot of my ebooks, but there are some that don't show the added spacing. What is happening? Is there something wrong with my Nook?

Chapter One
12-10-2013, 10:20 PM
I cant say I have noticed that with mine. Have you checked what line spacing option you have chosen, in the text options?

MartyTX
12-10-2013, 11:33 PM
Aiden,

In calibre, give this a try for a book that's on your Nook with the extra spacing:

Convert Books > Look & Feel > Select: Remove Spacing Between Paragraphs

Delete the book already on your Nook and add the one with the Remove Spacing option selected.

AnemicOak
12-10-2013, 11:39 PM
What happens if you toggle "Publisher Defaults" on/off?

gbm
12-10-2013, 11:59 PM
Most of the e-books that I transfer to my Nook Simple Touch get added extra spacing between the paragraphs, but previewing them on Adobe Digital Editions and on Calibre (What I use for transfer) shows no spacing at all. I tried transfering with Calibre and manually, but it makes no difference. This happens with a lot of my ebooks, but there are some that don't show the added spacing. What is happening? Is there something wrong with my Nook?

I think this thread (http://www.mobileread.com/forums/showthread.php?t=223586) may help with your problem. Post #13 (http://www.mobileread.com/forums/showpost.php?p=2646765&postcount=13)-#21. Nook does not like condensed margins when not using publisher defaults.

luck
bernie

Aiden
12-11-2013, 01:15 AM
I cant say I have noticed that with mine. Have you checked what line spacing option you have chosen, in the text options?

It's the narrowest one, the problem is the spacing between paragraphs, the line spacing is normal.

Aiden,

In calibre, give this a try for a book that's on your Nook with the extra spacing:

Convert Books > Look & Feel > Select: Remove Spacing Between Paragraphs

Delete the book already on your Nook and add the one with the Remove Spacing option selected.

I tried it already on two different books, it doesn't fix it, because when I preview the e-book on calibre, the spacing is normal :/

What happens if you toggle "Publisher Defaults" on/off?

This is actually interesting, it fixes the problem, but I find it kinda uncomfortable, because if I change anything like the typeface or the margins it adds the extra spacing again.

I think this thread (http://www.mobileread.com/forums/showthread.php?t=223586) may help with your problem. Post #13 (http://www.mobileread.com/forums/showpost.php?p=2646765&postcount=13)-#21. Nook does not like condensed margins when not using publisher defaults.

luck
bernie

How do I edit the css? I tried Sigil, but can't find the section mentioned in the post #19? :blink:

Thank you all for your answers! :)

gbm
12-11-2013, 10:05 AM
It's the narrowest one, the problem is the spacing between paragraphs, the line spacing is normal.



I tried it already on two different books, it doesn't fix it, because when I preview the e-book on calibre, the spacing is normal :/



This is actually interesting, it fixes the problem, but I find it kinda uncomfortable, because if I change anything like the typeface or the margins it adds the extra spacing again.



How do I edit the css? I tried Sigil, but can't find the section mentioned in the post #19? :blink:

Thank you all for your answers! :)
The easiest way--if the ebook is a calibre conversion to start-- is to reconvert with the Expand CSS option checked. Next is to do a epub to epub with Expand CSS checked.
116529
You can also edit the margin in the css file, but this will mean the you will have to edit every margin in the css file.
example:
{

margin: 0
}
This condensed margins this gives a margin of 0 top, bottom , left and right.

You would want to change that to:
{
margin-bottom: 0;
margin-left: 0;
margin-right: 0;
margin-top: 0
}
for the nook to display correctly.

See this for condensed margins (http://codex.wordpress.org/CSS_Shorthand)help.

bernie

Section8
12-11-2013, 10:10 AM
If you don't want to bother with editing CSS, you can do a calibre epub->epub conversion to fix this. I'm not at home with calibre running right now to remember it exactly, but I think in the "Look and feel" dialog, there is an "expand CSS" setting (or something like that) that expands the shorthand "margin" css statements that the nook doesn't handle.

Aiden
12-11-2013, 12:17 PM
The easiest way--if the ebook is a calibre conversion to start-- is to reconvert with the Expand CSS option checked. Next is to do a epub to epub with Expand CSS checked.
116529
You can also edit the margin in the css file, but this will mean the you will have to edit every margin in the css file.
example:
{

margin: 0
}
This condensed margins this gives a margin of 0 top, bottom , left and right.

You would want to change that to:
{
margin-bottom: 0;
margin-left: 0;
margin-right: 0;
margin-top: 0
}
for the nook to display correctly.

See this for condensed margins (http://codex.wordpress.org/CSS_Shorthand)help.

bernie

If you don't want to bother with editing CSS, you can do a calibre epub->epub conversion to fix this. I'm not at home with calibre running right now to remember it exactly, but I think in the "Look and feel" dialog, there is an "expand CSS" setting (or something like that) that expands the shorthand "margin" css statements that the nook doesn't handle.

I converted a book again with the "expand CSS" enabled and it worked! I disabled publisher defaults and now the extra spacing between paragraphs is not there! I feel silly for fixing it so easily. Thanks! :thanks: