View Full Version : blank pages after SVG images in Kobo


jobalcaen
10-09-2012, 02:21 PM
Hello everyone,

My book cover displays perfectly in ibooks, ADE and firefox reader.

However, when I open the book in the Kobo app on the ipad and in FBreader, the cover appears correctly but a blank page is inserted after.

I followed the advice on this website to create my cover page http://denis.papathanasiou.org/?p=592 and tried googling this issue but I can't find anything of much use.

Should I stop using SVG, resize my images to 800x600 and use a simple <div> and <img ....> combo?

I also attached a sample of the book that is giving me issue.

Any input would be appreciated.

Thanks,

jobalcaen
10-11-2012, 03:07 AM
I was finally able to resolve my own issue. The solution was to reduce the width and the height of the svg to 99% instead of 100%. I guess there is somekind of a hidden margin that does not get removed even though I set the margins for everything to 0 in the css. Here is an example of the code I used:

<?xml version="1.0" encoding="utf-8" standalone="no"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title></title>
<link href="../Styles/style.css" rel="stylesheet" type="text/css" />
<style type="text/css">
/*<![CDATA[*/

@page {padding: 0pt; margin:0pt}
body { text-align: center; padding:0pt; margin: 0pt; }
/*]]>*/
</style>
</head>

<body>
<div>
<svg xmlns="http://www.w3.org/2000/svg" height="99%" preserveAspectRatio="xMidYMid meet" version="1.1" viewBox="0 0 524 612" width="99%" xmlns:xlink="http://www.w3.org/1999/xlink">
<image height="612" width="524" xlink:href="../Images/image001.png"></image>
</svg>
</div>
</body>
</html>

I tested this successfully in ibooks, kobo reader app on the ipad, Sony PRS-505, firefox epubreader, FBreader and ADE.

FunkeXMix
05-19-2013, 01:31 PM
removed

FunkeXMix
05-19-2013, 02:19 PM
removed