View Full Version : InDesign CS6 and Sigil issue


tuxedo73
09-06-2012, 02:26 PM
Hi all,

My question is about something, not much of a problem, but strange issue i've come across lately.

I exported sample cyrillic text from InDesign CS6, did some metadata edit in Sigil 0.5.3 and everything went Ok. I mean that ePUB file was fully readable in ADE, iOS BlueFire and Azardi.
But when I exported this file to my e-Book reader (Prestigio PER5062B (http://www.prestigio.com/products/eBook-readers/3-series/eBook-Reader-PER5062B)) all cyrillic leters was replaced with "?", except the latin ones and digits.
I found, that if I open file in the book reader right after export, without any edit in Sigil, text reads fine. But if I edit it there, put simple space between two leters, or even just open/save, all characters are displayed with "?" again. Tried different fonts too.

And finaly, when I extract ePUB and edit *.opf file deleting this line:

<meta content="0.5.3" name="Sigil version" />

after repack, the ePUB is fully readable in any reader again.

The same ePUB, exported from InDesign CS5.5, is readable everywhere, with or without edit in Sigil.

So I'm curious, if someone have any idea which change in CS6 ePUB export is the reason for this.

Thanks in advance!

...aand excuse me for my english.

Toxaris
09-06-2012, 04:06 PM
It almost sounds like an unicode issue, either the declaration in the files or the formatting of the files.

DiapDealer
09-06-2012, 04:19 PM
I remember someone else on here a while back having a world of issues getting a Prestigio device to work properly with Sigil output. Some kind of weird structural requirements, I believe.