View Full Version : Book Designer Freezes.


ayrapetov
11-30-2007, 08:15 PM
Hello. My question is that this: Everytime I try to use Book Designer to change a file into a .imp, Book Designer just says "Saving Book pages (0%)"

It never changes from 0%. Is there anything that can be done? Am I doing something wrong? I have tried different versions of book designer and different books and different formats. Nothing works. Thanks in advance.

JSWolf
11-30-2007, 08:17 PM
What OS are you running? if it is Vista, have you read all the directions in the Book Designer sticky? You should read the entire thread and then follow the directions for how to install on Vista if that's what you are using.

http://www.mobileread.com/forums/showthread.php?t=11786

ayrapetov
11-30-2007, 08:27 PM
I am running Vista, but I checked through all the updates and fixes and got the program to run on my machine. Those fixes and updates seem to help you RUN it on Vista, (which I couldnt do earlier) but I am past that stage.

JSWolf
11-30-2007, 08:31 PM
Are you running Book Designer from within Program Files? If so, try uninstalling and reinstalling outside of Program Files. Maybe it's that you don't have the proepr access to write the temp file(s) there.

ayrapetov
11-30-2007, 08:35 PM
I am running Book Designer outside of program files. It can't be that I don't have proper access, because:

When I click to make an imp file, it says that the file is in a foreign language, and asks if I would like to turn multi language support on. If I select no, it gives me a much more basic selection, at which point it does write an imp file but in gibberish. If I select to turn on multi language support, the more advanced window pops up, and at which point this problem occurs.

DaleDe
12-01-2007, 12:31 AM
I am running Book Designer outside of program files. It can't be that I don't have proper access, because:

When I click to make an imp file, it says that the file is in a foreign language, and asks if I would like to turn multi language support on. If I select no, it gives me a much more basic selection, at which point it does write an imp file but in gibberish. If I select to turn on multi language support, the more advanced window pops up, and at which point this problem occurs.

Selecting multiLanguage causes it to create images instead of text. The file size will be much bigger (3 to 5 times) after you get it to work. What do you mean gibberish? What language are you building for? Change the default to french and see what it does.

Dale

JSWolf
12-01-2007, 12:49 AM
Don't use French. French causes all sorts of nasties. German works very well. I've been using German and it works very well. Plus I've never had a problem with IMP output.

DaleDe
12-01-2007, 12:22 PM
Don't use French. French causes all sorts of nasties. German works very well. I've been using German and it works very well. Plus I've never had a problem with IMP output.

Hmm, I don't have as much experience with this as you do so you are probably right. The important thing is not to use English since, by default accented characters are converted to Russian. It is a silly bug. But for simple text any of the languages should work. I don't understand the original posters comment of gibberish and he hasn't posted back to explain what is happening.

Dale

ayrapetov
12-01-2007, 05:41 PM
I have been talking with JSWolf in private message, and it seems as though he isn't able to help me. (He hasnt answered me back.)

I should have mentioned earlier, the text of my ebooks is in Russian. As I said earlier, when I select the default (English) language, the text shows up in gibberish, what I mean by this is that it's just charecters that cannot be read. For example:

" ,
...
. ""?
. "


When selecting other languages, (German, French, English) the same problem persists.

DaleDe
12-02-2007, 12:12 PM
I have been talking with JSWolf in private message, and it seems as though he isn't able to help me. (He hasnt answered me back.)

I should have mentioned earlier, the text of my ebooks is in Russian. As I said earlier, when I select the default (English) language, the text shows up in gibberish, what I mean by this is that it's just charecters that cannot be read. For example:

" ,
...
. ""?
. "


When selecting other languages, (German, French, English) the same problem persists.

Select Russian. YOu may need to get more files from the Russian site for font support but it is certainly supported.

Dale

JSWolf
12-02-2007, 12:16 PM
ayrapetov, The HTML0 file that you sent to me is empty. There is no content in it, so I cannot test it out with my install of Book Designer.

ayrapetov
12-02-2007, 07:55 PM
I have been experimenting with Book Designer lately, and I still cannot get past this problem. When making an imp file, where can I select russian as a language? After turning on multi language support, I do not see any options. Please advise. Thank you.

DaleDe
12-02-2007, 08:11 PM
I have been experimenting with Book Designer lately, and I still cannot get past this problem. When making an imp file, where can I select russian as a language? After turning on multi language support, I do not see any options. Please advise. Thank you.

You don't select multilanguage. As I said, this creates a picture not text. On the main input screen you select configuration > settings and then select Russian. After the selection you will see the language in the lower left hand corner. It is the same place you said that you used to select languages. Then you don't select multilanguage and then you build the file. You will need a Russian rom in your eb1150 to view the results.

Dale