View Full Version : HELP! Calibre won't recognize my Kindle anymore!!

11-06-2011, 03:50 PM
I just installed the latest update, 0.8.25 and all was fine. BUT, after giving in to the nagging blue bar telling me some Kindle plugin has been updated, I did so the activated it -- some plugin that would enable me to control folders, etc. on my Kindle from Calibre. NOW try as I might, Calibre refuses to read my communication, no nothing! I even tried reinstalling Calibre, but still nothing.

Can anyone please help me??:help::help:

11-06-2011, 03:58 PM
Moved to PI where I think this will get attention

11-06-2011, 04:47 PM
You should follow the steps indicated in this sticky ( Note that the last one gets diagnostic information that you can post to the forum to let others help diagnose your problem.

11-06-2011, 04:59 PM
I followed every one of the steps you have in your sticky -- rebooted my WinXP PC as well as the Kindle 3 -- nothing helped. The information from "debug device detection" provided me with a message to copy & paste provided info somewhere, but there was no info to copy c&p! Strange...

What appeared to correct the problem was plugging the Kindle 3 into my laptop, also running Calibre -- that detected my device. After being reassured the problem was with my setup not my device, I re-plugged the Kindle into my main PC, fired up Calibre and -- inexplicably -- it was recognized. I tried it several times and all was/is well.

This is a very curious phenomenon I've never seen before. Somehow that "Kindle 2/3 Device Interface" plugin update was the cause -- can't explain it. But I disabled then re-enabled it which may or may not have helped fix my problem.

Thank you for Calibre -- and a speedy response on a Sunday evening:))