View Full Version : newbie ePub check error question


jw76
11-01-2011, 11:45 AM
I'm new to this forum so apologies if I'm posting this in the wrong place.

I'm trying to modify an existing ePub file to include a link to an Amazon page, and I'm getting the following error message from the ePub checker: "The reference to entity "tag" must end with the ';' delimiter". Based on some cursory research I think the problem is that the link I'm trying to add contains an ampersand. I saw previous posts that said to change the "&" to "&" but I tried doing that and it didn't change anything. I have little/no experience with coding, so there might be something really basic that I'm missing. I picked the link up directly from another ePub file and am stymied as to why it works fine in one file but not in another. Any help would be appreciated.

This is the whole link (though I've altered some text to say "dummy" based on company policy but what I've altered doesn't contain any special characters or spaces):

<a href="http://www.amazon.com/gp/redirect.html?ie=UTF8&location=http%3A%2F%2Fwww.amazon.com%2Fs%3Fie%3DUT F8%26ref_%3Dnb_sb_noss%26field-keywords%3Ddummy%2520dummy%2520dummy%2520on%26url% 3Dsearch-alias%253Ddigital-text%23%3Frh%3Dn%3A133140011%2Ck%3Adummy%20dummy%2 0dummy%20on&tag=dummy-20&linkCode=ur2&camp=1789&creative=390957">

DaleDe
11-01-2011, 10:42 PM
I'm new to this forum so apologies if I'm posting this in the wrong place.

I'm trying to modify an existing ePub file to include a link to an Amazon page, and I'm getting the following error message from the ePub checker: "The reference to entity "tag" must end with the ';' delimiter". Based on some cursory research I think the problem is that the link I'm trying to add contains an ampersand. I saw previous posts that said to change the "&" to "&amp;" but I tried doing that and it didn't change anything. I have little/no experience with coding, so there might be something really basic that I'm missing. I picked the link up directly from another ePub file and am stymied as to why it works fine in one file but not in another. Any help would be appreciated.

This is the whole link (though I've altered some text to say "dummy" based on company policy but what I've altered doesn't contain any special characters or spaces):

<a href="http://www.amazon.com/gp/redirect.html?ie=UTF8&location=http%3A%2F%2Fwww.amazon.com%2Fs%3Fie%3DUT F8%26ref_%3Dnb_sb_noss%26field-keywords%3Ddummy%2520dummy%2520dummy%2520on%26url% 3Dsearch-alias%253Ddigital-text%23%3Frh%3Dn%3A133140011%2Ck%3Adummy%20dummy%2 0dummy%20on&tag=dummy-20&linkCode=ur2&camp=1789&creative=390957">

Well the UTF8&location needs the & changed to a %38 also on&tag and there are some spaces in the hfref that are not permitted.