View Full Version : epub build problem Windows 7 and PKZIP.


fixit9660
10-29-2011, 12:13 PM
Hi all hope you can help. I'm running Windows 7 Pro with PKZIP for Desktop. I've also got a Kobo Touch. I'm trying to make the simplest .epub eBook ever; just a cover and one page. (I'll tell you the reason later.)
I've followed jedisaber.com 's instructions to the letter, and once I actually managed to get the book to upload into Calibre (great product by the way). But here's my problem. No matter what I do I can't get the ebook to verify here http://www.threepress.org/document/epub-validate/ or get my eReader to show it at all. The verify website continually tells me that:
1.ERROR: mimetype.epub: length of first filename in archive must be 8, but was 9
2.ERROR: mimetype.epub: OPF file OEBPS\content.opf is missing

I think 1. is due to Windows and/or PKZIP (not command line version, GUI only), although I understand the need for mimetype first and uncompressed.
I think 2. is due to Windows 7 but can't prove it. I've tried many many permutations of the "OEBPS\content" file path, to no avail.
Please can anyone help?:smack:
Thanks in anticipation, Andy.

wallcraft
10-29-2011, 12:54 PM
If you have it in Calibre, try Tweak ePub (right click on the ebook and select this from the drop-down menu). This explodes the zip into its parts for you to edit and then recreates the epub. It uses the correct ZIP options when it rebuilds the ePub, so you may not need to actually edit.

There is also a Modify ePub (http://www.mobileread.com/forums/showthread.php?t=154371) Plugin for Calibre, which might help if you are not sure what is wrong with the ePub.

fixit9660
10-29-2011, 02:30 PM
Thanks for that wallcraft!!
I used Tweak ePub and rebuilt the file and lo - it got rid of validate error number 1 Whoopee!!!:) So this MUST have been due to Windoze and/or PKZIP.
Then I installed Modify ePub and in spite of it locating and helping to clear out 1 extra file and adding one missing (.png) file, I still fails vallidate test 2. with the same error.
Why do I think this is going to be due to a similar cause?:blink:

Thanks again!!
Andy.

fixit9660
10-29-2011, 03:03 PM
AHA!!! Would you believe it? From earlier reading at jedisaber.com and other instructional websites I'd changed the OEBPS/container.opf to a Backslash; well it's running on Windoze after all. Nothing spotted it but in sheer desperation I returned it to a forward slash and it worked!!!!!
Why didn't they say "just use this file as it is". It says it points to the root folder, but it's a RELATIVE root folder, not an ABSOLUTE root folder. JeeeeZ!:smack:
ebook now passes all the validation and uploads to the ereader. OK it took two attempts to upload, don't know why, and the Cover picture is missing. oh and it has an extra page one which is blank. BUT it gets there and is readable.
YEEEHAAA!!!!!!! It's only taken me a week of nights....:dizzy::dizzy: