View Full Version : Text still full justifying on iPad, even through style says align left


SamL
09-28-2011, 12:16 PM
So I've been having this problem with my book, all of my titles, if the go more then one line, will fully justify on the iPad. Usually I just change the style to align:left, and that takes care of it. But I'm still having the problem on this book and I'm not sure why.

Here is my code:
<p class="header">22. The Freeway Philharmonic</p>
<p class="BT-NoIndent">One of the San Francisco Bay Areaís great musical treasures is its freelance pool of classical musicians. Skilled, devoted, and often overworked, this group of some 400 instrumentalists provides the musical core of many of our regionís performing ensembles. ...



p.header {
font-family : Times, serif;
font-size : 1.6em;
text-decoration : none;
font-variant : normal;
line-height : 1.42;
text-align: left;
color : #000000;
text-indent : 0px;
margin-bottom: 27px;
-webkit-hyphens:none;
adobe-text-layout: optimizeSpeed; <--! This is just to avoid hyphens on the Nook -->

}


And here is how it looks on the iPad:
http://img101.imageshack.us/img101/2695/ipadexample.jpg

Any help or suggestions would be appreciated, thanks.

susan_cassidy
09-28-2011, 02:54 PM
Is this using iBooks? Have you tried another ePub-reading app to see if it displays differently on it?

Toxaris
09-28-2011, 03:09 PM
Actually I don't see anything wrong. The header is left aligned. The text isn't, but you didn't post the class BT-NoIndent. If you have a problem with the text, we will need the description of that class.

SamL
09-28-2011, 03:56 PM
Actually I don't see anything wrong. The header is left aligned. The text isn't, but you didn't post the class BT-NoIndent. If you have a problem with the text, we will need the description of that class.

This is the code for the BT-NoIndent class:

p.BT-NoIndent {
font-family : Times, serif;
font-weight : normal;
font-size : 1em;
line-height : 1.2;
text-align : left;
color : #000000;

}

SamL
09-28-2011, 03:58 PM
Is this using iBooks? Have you tried another ePub-reading app to see if it displays differently on it?

Yes this is an ibooks only problem so far, I've tested it on the Nook and Kindle as well. But my company mainly proofs on the iPad, and we sell most of our books through apple, so I'd like to get this optimized for ibooks.

adv_dp_fan
09-28-2011, 04:24 PM
Is it just the one book or are all your books on iBooks doing it? iBooks does have a "Full Justification" option in its settings page that will ignore alignment settings in the book but if it is just the one book than that wouldn't be your issue.

SamL
09-28-2011, 05:06 PM
Is it just the one book or are all your books on iBooks doing it? iBooks does have a "Full Justification" option in its settings page that will ignore alignment settings in the book but if it is just the one book than that wouldn't be your issue.

its only this book. I've done several books with similar format, and this problem hasn't happened. I've even gone as far as to use all the header code from working books and paste it in this one, but the problem is still there.

susan_cassidy
09-28-2011, 06:19 PM
It could be a weird side-effect from some other CSS error, maybe. Have you tried running the source through a validator, to see if anything pops up?

Toxaris
09-29-2011, 03:25 AM
Is there in the CSS perhaps a specific setting for justification of the p, html or body class? It could be, that iBooks does not do the inheritance quite well. If for example the p class is in the CSS setting the justification on, it should be overruled. However, it might be ignored for paragraphs.
I also seem to vaguely remember that you can do a setting to justify everything by default on the iBooks, in fact it is the default. Have you turned that off?

SamL
09-29-2011, 12:10 PM
Ah fixed it! Toxaris was right, in settings ibooks was set to full justification. Its weird I haven't run in to this until now though. Thanks for your help as always everyone.

JSWolf
10-01-2011, 08:55 AM
Ah fixed it! Toxaris was right, in settings ibooks was set to full justification. Its weird I haven't run in to this until now though. Thanks for your help as always everyone.

That isn't a fix. I think you'll find a lot of people are in full justification and this needs to be solved set that way.