View Full Version : Chainfire 3d


kennyminot
06-11-2011, 04:53 PM
I found this program designed to increase graphics performance for 1ghz devices. It installs and appears to work. So far, my experience is that it makes Angry Birds Rio totally playable, and Angry Birds without the background is awesome. The only problem is that it adds a blue tone to all the birds, which is a little strange if you are accustomed to their bright red color.

Check it out here:
http://www.mobileboxs.info/android-apps/root-chainfire3d-pro-v1-2/

Didn't seem to improve performance much on Fruit Ninja. :-(

Filark
06-11-2011, 06:42 PM
Sorry about Fruit Ninja, Kenny! :(

However, I might reinstall my Angry Birds Rio with this new info. Thanks!! :D

oldredfox
06-12-2011, 01:06 AM
Just ordered a Pocket eDGe a few days ago. I've been lurking around this forum since then trying to read up and get ready for when it arrives. I noticed you linked v1.2 of Chainfire 3d. And that up to v1.9 is available. Did the later version not work well for you?

Dumas
06-12-2011, 03:56 AM
Welcome to MR and the Edge forum.

kennyminot
06-12-2011, 11:46 AM
LOL - I didn't even think to check. I'll see if I can find the newer version.

oldredfox
06-12-2011, 05:09 PM
If you change the 2 to a 9 in your link, it works just fine. =) I'm curious if the newer version fixes the blue tone you noticed.

javese
06-13-2011, 12:56 AM
hi kennyminot,
How does it work with Plants vs Zombie?

emusan
06-13-2011, 11:40 PM
I just tried out the newer version on my PE and it does make Rio run silky smooth(mostly), and I didn't notice any blue-ing of the birds(unless its really slight, its probably not there). Unfortunately it didn't make Plants vs. Zombies work, that is most likely due to the serious lack of any decent graphical hardware on the eDGe, so it will probably never work, sadly.

kennyminot
06-14-2011, 12:17 AM
I'm no longer getting blue birds. Seems to have just been a weird glitch when I first installed it.

Leesterz
07-15-2011, 05:19 PM
How do you install this? I am not a software expert and I've been having difficulties installing and tweaking my PE. I downloaded the .rar file and I'm up to that point. v1.9

Unrelated: I looked into the sticky'd tweaks thread and was wondering about how I change those settings for build.prop. What is build.prop?

If anyone could give me a guide on installing/modifying stuff that would be very helpful as I wasn't able to find one!

Thanks everyone

emusan
07-15-2011, 05:25 PM
download a program such as 7-zip(link (http://www.7-zip.org/)), then install that, right click on the .rar file and click 7-zip and extract to... and select somewhere on your pc, then you should have a .apk file, this you can just copy over to your edge with a USB stick or over the provided USB cable and then install through ES file explore. You will need to be rooted first though, for that download the z4root app from the amazon appstore(or I can send it to you if you can't access amazon), and then use that to permanently root your device.

the build.prop is a file located in /system/ and is used to define various things about the device and its firmware build. There are a few guides around, you can find mine here: link (http://www.mobileread.com/forums/showthread.php?t=134733) step seven is what you want.

Hope this helps!

Leesterz
07-15-2011, 05:34 PM
Thanks so much Emusan, I'm surprised at how quickly people respond on this forum! I hope one day, when I learn a lot about this device, that I can help out some noobies. =)

emusan
07-15-2011, 05:47 PM
Thanks so much Emusan, I'm surprised at how quickly people respond on this forum! I hope one day, when I learn a lot about this device, that I can help out some noobies. =)

lol it really depends on the time, if I'm online and I've got some time I try to respond as fast as possible...

Filark
07-16-2011, 12:31 AM
Thanks so much Emusan, I'm surprised at how quickly people respond on this forum! I hope one day, when I learn a lot about this device, that I can help out some noobies. =)

You will, Leesterz, you will! :D Glad to have you here.

attemptress
07-17-2011, 03:04 AM
I tried this for a while, but didn't really notice any improvement. . . so I deleted it. Maybe I'll try it again some time, if the "unofficial testing" you guys are doing continues to go well.

MasterTec
07-18-2011, 10:48 AM
I installed ver 2.8 of this and now my PE won't boot. Just hangs on the main loading screen and then goes blank after about 10 minutes. Only thing that will stop it is pressing the reset button.

Restoring ermine hasn't fixed it. I guess it's off to the "I bricked my PE" thread for me...

emusan
07-18-2011, 10:59 AM
I installed ver 2.8 of this and now my PE won't boot. Just hangs on the main loading screen and then goes blank after about 10 minutes. Only thing that will stop it is pressing the reset button.

Restoring ermine hasn't fixed it. I guess it's off to the "I bricked my PE" thread for me...

try doing the dingo golden update...

MasterTec
07-18-2011, 11:41 AM
I tried. This is weird. I put the file on my USB stick and rename it "update.zip" and no it's not update.zip.zip

Then I insert the USB into my PE and power it up while holding down the menu and rotate buttons for over ten seconds.

After a few seconds it comes up with the "Updating software" message but that flashes off after about five seconds and then it just hangs. The loading screen does its "reflection" effect thing and all four dots light up but then it just flashes real quick and continues to do the same thing. After about ten minutes the screen goes blank.

The eInk side is stuck on "initializing" the whole time.

Anyhow.. this is the strange part. After this happens the update.zip file on my USB stick is GONE! Completely vanished. I even tried applying read only to it and still it disappears. This happens with dingo golden, ermine.. whatever.

I was reading the bricked thread but he goes on about replacing the build.prop file but I don't even know how to get that far! How do you access files on the PE when it won't even boot?!

emusan
07-18-2011, 11:59 AM
if you had enabled USB debugging before it got into this mess(I assume you had if you rooted) you can connect it to your computer through a USB cable and use adb to connect to the PE. However, it does not seem like the build.prop file is your problem, it was found that that file has very little to do with causing these kinds of problems.

At the end of the update.sh in the update.zip it does delete the file, this is some kind of security measure I guess, but it is supposed to happen.

Sorry, but I have no idea what could be causing your problem...

vicinc
07-18-2011, 06:41 PM
my bricked one that I can not STILL restore is doing the same. installed a old version of chainfire on that one but do not think is releated. on the working one I do have chainfire new version and is working ifne.

ivanjt
07-18-2011, 07:21 PM
my bricked one that I can not STILL restore is doing the same. installed a old version of chainfire on that one but do not think is releated. on the working one I do have chainfire new version and is working ifne.
It could in fact be the problem. If I remember correctly your e-ink screen is working but not the LCD.

Having seen some of the problems that people have had I think you may have over stressed the video sub system such that it no longer works - hence your blank screen.

I don't remember you mentioning you had loaded chainfire before or I would have mentioned this earlier.

If this is in fact the case then there is no way, short of a new main board, that you will get it working again. I will say that if you are ever down this way on holiday and you have it with you I'll take a look at it from the hardware side.

emusan
07-18-2011, 09:02 PM
ivanjt, its the other way around, his e-ink doesn't work, I think it may be due to missing esi libraries, though I'm not sure how to add them back or where to get them from...

vicinc
07-19-2011, 10:40 AM
emusan, you are right. my tablet is just a standard android now, the build.prop was restored via adb and got it booting. but eink is missing. I did copied all files in system from working one and still not working. I am thinking as my boot or recovery does not work, are they not there hidden somehow. the idiotic way of entourage of making the tablet uncrackable to community roms? it is so simple to have almost any apps done for the other screen as well if sdk available, but they wanted full control of the device. I hope chairman is amused to see it on woot or onesaleaday! grooooh groooh.

MasterTec
07-19-2011, 11:51 AM
I got mine working with the modified golden update (with the safety checks removed.) Both screens work fine and it's just like it was right out of the box.

I have since reinstalled the 2.2 update (the modified one with the G Apps) and everything is working fine... including the eInk. I ended up not messing with pushing files or anything like that.

Mine bricked after installing Chainfire3D v2.8. I won't be trying that software again.

westparker
07-20-2011, 08:30 PM
Has anyone seen any print apps besides printersshare that work on the PE?

kittenz96
08-14-2011, 08:43 PM
I got mine working with the modified golden update (with the safety checks removed.) Both screens work fine and it's just like it was right out of the box.

I have since reinstalled the 2.2 update (the modified one with the G Apps) and everything is working fine... including the eInk. I ended up not messing with pushing files or anything like that.

Mine bricked after installing Chainfire3D v2.8. I won't be trying that software again.

I am waiting for my new pocket edge to arrive, it still has 1.6 on it but I will be updating pretty much right out of the box. Where do I find a link to the modified 2.2 with G Apps at? Also, which version of chainfire worked best?

mokel22
08-14-2011, 09:11 PM
I am waiting for my new pocket edge to arrive, it still has 1.6 on it but I will be updating pretty much right out of the box. Where do I find a link to the modified 2.2 with G Apps at? Also, which version of chainfire worked best?

Chainfire killed an edge and has already forced two people's edges to golden update. I would avoid it if I were you. As for the modified 2.2, here is the link to the Custom ROM thread.
http://www.mobileread.com/forums/showthread.php?t=141833
Sorry for the negativity, but I almost lost my edge to Chainfire and I'd rather not you lose $115+ from it.

kittenz96
08-16-2011, 08:41 AM
Thank you for the link....my Edge is due in today, I will avoid Chainfire at your advice. I agree, don't want to lose my new tech. If I feel the absolute need to play angry birds, I can do it on my Inspire.

Leesterz
08-17-2011, 07:07 PM
Hey all.

Just to clear things up, Chainfire3D Pro v1.9 DOES work. I've had it installed for something like a month and no problems. I'm not sure how important this app is since I installed it shortly after rooting and updating to ermine. Never experienced games without it.

Link: http://www.rapidshare2download.net/forums/mobile-pda-iphone/801700-root-chainfire3d-pro-v1-9-a.html

ATFmac
08-17-2011, 07:30 PM
Hey all.

Just to clear things up, Chainfire3D Pro v1.9 DOES work. I've had it installed for something like a month and no problems. I'm not sure how important this app is since I installed it shortly after rooting and updating to ermine. Never experienced games without it.

Link: http://www.rapidshare2download.net/forums/mobile-pda-iphone/801700-root-chainfire3d-pro-v1-9-a.html

I was about to say this as well. When I got my PE going and got to CF3D, kennyminot suggested it while at ver1.3, someone suggested an updated version. I've been at ver1.9 for about two months and I've never had a problem with it. It's not really the best boost in performance to install casually, but if it doesn't brick like the newer version, it can't hurt. Of course you gotta decide for yourself.

Dingo
08-18-2011, 03:08 PM
I installed 1.9 version, but do not see much improvement. I tried different combination of settings in acceleration app, anyone what is right combination that RIO is playable ?

thanks

ivanjt
08-18-2011, 04:34 PM
I installed 1.9 version, but do not see much improvement. I tried different combination of settings in acceleration app, anyone what is right combination that RIO is playable ?

thanks
Simple answer - whatever works and doesn't kill the video sub system.

Push it too hard and you may end up with the BSOD.

Dingo
10-22-2011, 10:24 AM
Anyone tried chainfire 3D version 2.8 ?

ivanjt
10-22-2011, 06:11 PM
Anyone tried chainfire 3D version 2.8 ?
Still trying to brick your eDGe?

ATFmac
10-24-2011, 07:52 PM
Still trying to brick your eDGe?

hah +1

Dingo
10-27-2011, 05:31 PM
Still trying to brick your eDGe?

Yes I tried, but no luck, do I am quitting.
;)