View Full Version : setting up sync with Google


Mark Rehorst
06-06-2011, 02:15 AM
Over on the entourage forums there was a how-to posted on setting up gmail, google calendar, contacts, etc. I have searched the web and this forum and can't seem to find the procedure anywhere.

I can set up a gmail account that connects to the google server and grabs all my mail but I want to set up multiple accounts and get the calender and contacts sync functions working. I had it working a couple weeks ago but I've been downgrading and reinstalling ermine and have reset the device several times so all that stuff was cleared.

Getting everything to sync involved selecting the the "corporate" type account and setting the server to imap.google.com if I recall correctly. Ther was some other trick that had to be applied to the username, I think, but I have tried many combinations and can't seem to get it to connect to the server.

Can someone post the setup instructions?

Thanks!

MR

North19
06-06-2011, 01:47 PM
If I remember correctly, I did it using Froyo email this way:

1) put in gmail address and passwork, but do not click 'Next"; click "manual set-up"
2) pick exchange
3) put in m.google.com instead of mail.google.com or gmail.com (whatever the default was)

I think that was it for specifying info. It brought in my calendar and contacts when I did that.

I then set up all my other gmail accounts as regular gmail, and I switch back and forth between the separate and the combined inboxes, all through the same Froyo homepage. Somehow I have accumulated six gmail accounts for various purposes (one for computer registrations, etc, one for bulk mail, one for professional listserv memberships, one for a side job, one for personal email, one for a particular support group membership that runs hundreds of messages a month, etc) and this set-up on the PE works for me.

Mark Rehorst
06-06-2011, 08:08 PM
That worked! Thanks! :D

Here's the whole process for completeness sake and future reference:

I set up sync with google by using the Settings app. I opened the "Accounts and sync" menu, selected "Add account" (at the bottom of the screen), selected "Corporate", then entered my gmail address and password, hit "next", changed the server name to m.google.com, then hit "next".

The PE then connected to the google server and presented a menu of options about how much mail should be synced, sync calender, sync contacts, etc. I set these up as I liked and everything synced.

You can add additional accounts until you're blue in the face using the same process. :thumbsup:

Settings can be reviewed/changed by starting the Settings app, opening "Accounts and sync" and selecting the account that you want to mess with, or in the Froyo Mail app, select an account, hit the menu button, and select "account settings".

MR

attemptress
06-06-2011, 08:23 PM
When I tried this a while back, I was able to sync my "main" google calendar, but I don't actually use that one. What I want to do is sync a secondary calendar that I share with my co-workers (without copying every swiggin' event to my "main" calendar). I couldn't find a way to make this work. Ideas?

Filark
06-06-2011, 09:17 PM
Attemptress! This is your first post on MobileRead, so I will say Welcome!! :)

As to calendars I know virtually nothing. :p

kennyminot
06-06-2011, 10:17 PM
Of course, you can sync your calendar with some third party applications, but you're probably looking for a more seamless solution. For that, you need to go through the steps in emusan's Google Market fix: http://www.mobileread.com/forums/showthread.php?t=134733. While you can get some gapps to work in some limited ways without it, G-mail and Google Calendar won't automatically sync unless you setup your Google account through the usual process.

I hope this helps. Everything syncs perfectly on my eDGe! :-)

Gremalkin
09-21-2011, 02:41 PM
That worked! Thanks! :D

I set up sync with google by using the Settings app. I opened the "Accounts and sync" menu, selected "Add account" (at the bottom of the screen), selected "Corporate", then entered my gmail address and password, hit "next", changed the server name to m.google.com, then hit "next".

MR


I just ran the Ermine update, and the above isn't working for me. When I change the server name to m.google.com and hit next, I get "Unable to open connect to server"

Yes, I have internet access, I can browse the web.

I had 2 google accounts syncing with k-9 mail prior to the udpate, that were still there post-update, so I deleted them before trying to setup as above.

Any ideas?

OK - Note sure why, but now it is working. I rebooted (twice) and was finally able to set it up. I can see my calendar items!! Not sure what was going on at first??

So, nevermind. :-)

emilya
09-22-2011, 01:10 AM
Mark, thank you. My calendar is now synced thanks to you :)

jdkiefer
09-22-2011, 10:58 AM
Please pardon my lack of knowledge, as I am new to this android stuff.
I just received from woot my edge jr, and I am trying to tie my Google calender in to it, And I can't make it work, I also can't make MS exchange E-mail work. Do I need to upgrade to 2.2, or can I do this stuff with the OS that I have?
Also what do I gain by up dating my OS?
jdkiefer:thanks::thanks:

emilya
09-22-2011, 12:00 PM
jd, I don't know if it works on 1.6. I had already upgraded to 2.2 before setting up sync. The advantages to 2.2? Not sure, I assume more apps are compatible.

jamina1
09-22-2011, 02:48 PM
How is it that people are saying that they have their Gmail and calendar working? I can't even get one account to work. It says I have no data connection even though I'm connected to wifi.

I've tried doing it through the various apps and even the settings->accounts and sync and always receive the same error - no data.

stevesr0
09-22-2011, 09:25 PM
I had set up the gapps using emusan's approach, but did not have calendar syncing.

In fact, I notice that I have two different icons for calendar, one on the home screen with the android figure on it and one on the app screen that looks like a wirebound notebook with a spiral on the page.

When I click on the home screen calendar icon, a message appears that the app isn't installed.

When I click on the calendar icon on the app screen, it launches a calendar.

After using the Froyo mail approach, the calendar on the app screen now shows the one appointment I have set up on my computer on google calendar. Hurray.

However, I am puzzled by two things: (1) the existence of the android calendar icon (a non installed program that I cannot find on the system and (2) that on the Accounts and Sync page, "Local Calendar" is listed with "Sync is OFF".

When I look at the Corporate and google accounts (both with the same username/pword), they both list contact and calendar for syncing. Only the google account shows the rotating curved arrows that stand for syncing though.

Does this seem different from what other folks with calendar syncing have?

Thanks,

Steve