View Full Version : PE ermine hibernation problem


Mark Rehorst
06-06-2011, 02:10 AM
I reloaded the ermine update after downgrading back to dingo. With no apps added, I tested the hibernate function of closing the unit. What I have found is that there is a service called "esi update 2" that starts and runs automatically and it seems to interfere with the hibernation. If I manually stop that service the device will hibernate when I close it. Once the service starts up again, hibernation fails.

Is there any way to prevent the service from starting automatically?

emusan
06-06-2011, 10:10 AM
I think that service is to update the eink(probably to display the hibernation message)... are you sure that your device does not hibernate at all? Mine usually takes about a minute or so to hibernate after closing it.

obsessed2
06-06-2011, 10:53 AM
You can manually check to see if the PE will hibernate. Press and hold the Rotate button on the LCD side and eDGe options should pop up. Select Hibernate and see what happens. Also, you can adjust Hibernate Timeout under Settings and Power Saving.

Mark Rehorst
06-06-2011, 09:10 PM
It works fine manually, and comes out of hibernation reliably. It just doesn't hibernate when I close the device.

emusan
06-06-2011, 09:14 PM
And just to confirm, you have left it closed for over a minute and the light on the bottom stayed solid even after that amount of time?

And if your edge is rooted could you post the logcat of what happens when you close the lid? It could be helpful in determining the problem(I'm guessing you made one to find out about the esi.update thing)...

Mark Rehorst
06-07-2011, 03:19 AM
It sits closed for hours without going into hibernate. Further tests with the esiUpdate2 service now point elsewhere. My device is not rooted.

obsessed2
06-07-2011, 08:38 AM
This might sound a little crazy and you may have already done it but, check the WiFi sleep policy. Something has to be keeping the hibernate from turning on automatically and this might have something to do with it. To check it, Settings, Network controls, Wi-Fi settings, press and hold Menu Button and select Advanced then Wi-Fi sleep policy. If it is set to Never, change it and see what happens. Next theory: Is your screen timeout disabled? You can check it using the Power Control widget. Long press anywhere on the desktop where there is no icon and Widgets will come up. Select Power Control and make sure the Light Bulb is turned off. Next theory: Maybe hibernation with the lid closed is triggered by a physical sensor. Check the camera lens to make sure the little plastic protective cover is removed. Something has to trigger the PE to go into hibernate when the lid is closed. Not saying this is the trigger but I can't say for sure it isn't either. Next theory: Check the optical sensor to make sure it works. Again, these are suggestions and may not have anything to do with the problem. Hopefully you figure it out.

yugami
06-07-2011, 09:23 AM
I noticed yesterday that my pe does not hibernate when I turn wifi off. Turn it back on and everything works as it should.