View Full Version : Book Cleaner files v1.7 2009-02-20


JSWolf
06-23-2007, 09:24 PM
With the help of Harry T and vvv I've been able to tweak Book Cleaner (part of Book Designer) and now I have them set so they work well. 1.bcf and 2.bcf are before and after files 1 is before and 2 is after.

Just put them in your bookcleaner directory and then run Book Cleaner from BD and you'll be able to make use of them.

Jon

Note: Version 1.0 downloaded 59 times.
Note: Version 1.1 downloaded 9 times.
Note: Version 1.2 downloaded 17 times
Note: Version 1.3 downloaded 262 times
Note: Version 1.4 downloaded 83 times
Note: Version 1.5 downloaded 795 times
Note: Version 1.6 downloaded 471 times
Note: Version 1.7 downloaded 952 times

I had setup in Book Cleaner a fix so OE did not become emdashes. That problem was because when I did it, I was using the French language. Well, because I'm using German, that no longer needs to be fixed. Also, that fix causes graphics from LIT files to sometimes be missed. It picks up the cover, but not the rest of the graphics. So anyway, here is version 1.7. If you have version 1.0-1.6, please update with this version.

Added 1.8 to fix loading of graphics

JSWolf
07-24-2007, 05:47 PM
Book Cleaner files version 1.1

Fixes a St. where it can cause a new paragraph.

RWood
07-24-2007, 07:10 PM
What else does it do other than correct the "St." problem?

NatCh
07-24-2007, 08:26 PM
The old one fixed emdashes too. I was just about to search for this file again, JSWolf (I apparently wiped the ones I had :sad:), so I'm especially glad that you chose today to update it. :grin:

JSWolf
07-24-2007, 08:31 PM
It fixes...
emdashes
Mr.
Mrs.
St.
-- to emdash
?
. And,
“ + space to just “
oe
Dr.
That's what gets fixed. If anyone else knows of anything that needs fixing, please say so here and I can add it in.

JSWolf
07-25-2007, 11:38 PM
Version 1.2 fixes a mistake I made with . And that caused things like Mr. and to become Mr. And. I forgot to check case specific. Now it works fine. Should be no more bugs.

JSWolf
08-18-2007, 06:01 PM
One thing that was forgotten to be mentioned is that in order to preserve the proper dashes (reglar, emdash, etc.), when you go to make the Sony Reader (LRF) file, select the options tab and under misc make sure dashes is set to "as it is" and then dashes will not be converted.

NatCh
08-20-2007, 10:26 AM
Thanks for that reminder, JSWolf, I'd forgotten it. :nice:

JSWolf
08-21-2007, 06:55 AM
Thanks for that reminder, JSWolf, I'd forgotten it. :nice:
I only remembered when trying to help HarryT fix the emdashes with the Queens Own FBI series and he said he's using the Book Cleaner 1.3 files. The default I think is to convert the dashes. And that does blow away the emdashes for sure.

rjnagle
08-21-2007, 09:38 AM
Unclear about the install instructions. I installed Book Designer from a week ago. I'm assuming book cleaner files go in C:\Program Files\Book Designer 4.0\BookCleaner . I'm supposed to add only 2.bcf but not 1.bcf? Do I need to rename it or overwrite anything? The directory already has MiddleDashes_before and MiddleDashes_after.

JSWolf
08-21-2007, 09:46 AM
Unclear about the install instructions. I installed Book Designer from a week ago. I'm assuming book cleaner files go in C:\Program Files\Book Designer 4.0\BookCleaner . I'm supposed to add only 2.bcf but not 1.bcf? Do I need to rename it or overwrite anything? The directory already has MiddleDashes_before and MiddleDashes_after.
1.bcf and 2.bcf both go in the bookcleaner directory. Then run Book Cleaner and then select 1.bcf as the input file before formatting and 2.bcf as the input file after formatting. Then close Book Cleaner and load the next book and it'll do it's magic. But, every so often, run Book Cleaner to make sure they are still selected. In the versions of BD before July 2007, it was possible to lose the BC settings and the BC files would just need to be selected again. Don't know about the July 2007 version and if it loses it's settings.

HarryT
08-21-2007, 09:55 AM
In particular, if you open a second copy of BD (very useful when compiling "omnibus" books to copy and paste from one to another), the 2nd copy will have the BD "default" settings rather than the ones you've selected.

RWood
09-27-2007, 02:19 PM
Reference to this thread now added to the BookDesigner Wiki. (http://wiki.mobileread.com/wiki/Book_Designer)

JSWolf
09-27-2007, 05:52 PM
Reference to this thread now added to the BookDesigner Wiki. (http://wiki.mobileread.com/wiki/Book_Designer)
I just took a look at the Wiki and fixed a couple errors with regards to the latest BD update. ALso, I cannot finmd the reference to this thread in the wiki.

shen
12-13-2007, 05:43 AM
If have some problems with dialogs. From the original PDF, dialogs start with two spaces and are separeted by a line break. It looks like this:

Sein Gesichtsausdruck blieb unverändert. Seine gefalteten
Hände ruhten friedlich auf dem Deckenrand, und die Hitze, in
der ich mir vorkam wie ein Suppenhuhn beim Sieden, schien
ihn nicht einmal zu wärmen.
»Muß ich höflich sein?« fragte ich. »Oder geht´s auch mit
Offenheit?«
»Ich habe nicht bemerkt, daß Sie unter großen Hemmungen
leiden, Mr. Marlowe.«
»Streunen die beiden Mädchen gemeinsam durch die
Gegend?«
»Ich glaube kaum. Sie rennen wohl auf getrennten und leicht
voneinander abweichenden Wegen in ihr Verderben. Vivian ist
verzogen, anspruchsvoll, raffiniert und ziemlich skrupellos.
Carmen ist ein Kind, das den Fliegen gern die Flügel abreißt.
Keine von beiden hat mehr Moral als eine Katze. Ich übrigens
auch nicht. Kein Sternwood hat je welche gehabt. Fahren Sie
fort.«
»Vermutlich hatten sie eine gute Erziehung. Wissen Sie, was
sie tun?«

After conversion, dialogs are no more separeted, which is hard to read. It looks like that:

Sein Gesichtsausdruck blieb unverändert. Seine gefalteten
Hände ruhten friedlich auf dem Deckenrand, und die Hitze, in der
ich mir vorkam wie ein Suppenhuhn beim Sieden, schien ihn nicht
einmal zu wärmen. »Muß ich höflich sein?«fragte ich. »Oder geht´s
auch mit Offenheit?« »Ich habe nicht bemerkt, daß Sie unter großen
Hemmungen leiden, Mr. Marlowe.« »Streunen die beiden Mädchen
gemeinsam durch die Gegend?« »Ich glaube kaum. Sie rennen wohl
auf getrennten und leicht voneinander abweichenden Wegen in ihr
Verderben. Vivian ist verzogen, anspruchsvoll, raffiniert und ziemlich
skrupellos.
Carmen ist ein Kind, das den Fliegen gern die Flügel abreißt.
Keine von beiden hat mehr Moral als eine Katze. Ich übrigens
auch nicht. Kein Sternwood hat je welche gehabt. Fahren Sie fort.«
»Vermutlich hatten sie eine gute Erziehung. Wissen Sie, was sie tun?«

Any idea, how this can be fixed?

Stefan

JSWolf
12-13-2007, 09:21 AM
That does load fine when you have quotes istead of whatever those symbols are.

What you can do is use Book Cleaner for this.....

Go to Book Cleaner and select 1.bcf.
Add in a row
Convert » to “
Add another row
Convert « to ”
Now save

Select 2.bcf
Convert “ to »
Add another row
Convert ” to «
Now save

Then close Book Cleaner and reload the file.

I just tested this and it does work.

shen
12-13-2007, 09:31 AM
Thanks Jon, works well :-)

What about including this into your BCFs as v1.4? :-)

Stefan

JSWolf
12-13-2007, 10:26 AM
Thanks Jon, works well :-)

What about including this into your BCFs as v1.4? :-)

Stefan
I'll have to test it first. But yes, I can add it in if it works.

shen
12-13-2007, 10:30 AM
If you need the PDF for testing, just me let me know by mail.

Stefan

JSWolf
12-13-2007, 10:36 AM
Added 1.4 to fix « and » ... see the first post in this thread.

shen please download the 1.4 BC files as I tweaked it to fix a problem my instructions caused.

shen
12-13-2007, 12:02 PM
v1.4 works as it should, thanks again :-)

Stefan

JSWolf
12-13-2007, 12:49 PM
You are very welcome.

HarryT
12-13-2007, 12:53 PM
That does load fine when you have quotes istead of whatever those symbols are.


The Windows "Character Map" tool calls them "Double Angle Quotation Marks". They're very commonly used in some European languages.

JSWolf
12-13-2007, 01:57 PM
Well, I have sorted out the double angle quotation marks in Book Designer. Didn't take long at all using Book Cleaner.

tompe
12-16-2007, 06:20 PM
The Windows "Character Map" tool calls them "Double Angle Quotation Marks". They're very commonly used in some European languages.

In Swedish they are called "gåsögon" (goose eyes) but they are mostly used in older texts. They are also called chevrons and guillemots.

HarryT
01-08-2008, 03:05 AM
New additions for "not breaking on full stops": add:

M.
Mme.
Messrs.

These should all be case sensitive and handled in the same way as "Mr." etc.

JSWolf
01-08-2008, 10:09 AM
New additions for "not breaking on full stops": add:

M.
Mme.
Messrs.

These should all be case sensitive and handled in the same way as "Mr." etc.
Version 1.5 added to include the fixes HarryT mentioned above.

HarryT
01-08-2008, 12:44 PM
Thanks Jon!

JSWolf
01-13-2008, 08:41 PM
I kind of gave up on using uni characters as I figured I might end up screwing something up big time.

HarryT
01-15-2008, 02:31 AM
Could you elaborate on that last remark, Jon? I don't quite follow what you're saying!

DMcCunney
01-15-2008, 03:07 AM
Could you elaborate on that last remark, Jon? I don't quite follow what you're saying!I think he means he's staying far away from UniCode.
______
Dennis

HarryT
01-15-2008, 05:30 AM
OK, but what does that have to do with Book Cleaner?

Patricia
01-15-2008, 07:12 AM
I may be wrong, but seem to remember that earlier versions of book cleaner had a bug where 'oe' came out as an emdash. This was because the oe unicode character was used to substitute for emdashes at some stage in the cleaning process. When it came to the replacement stage odd things happened.

HarryT
01-15-2008, 07:55 AM
Yes, ISTR that occured if you had the book language set to "English". As you know this (rather surprisingly) is the wrong choice in BD :). "German" works the best for me.

JSWolf
01-15-2008, 08:23 AM
If you look in the list of find what and replace what, you will see initially uni characters were used. I've stopped using uni characters as I'm not sure which ones nobody wants to ever use.

Roberts324
02-21-2008, 05:05 AM
If you look in the list of find what and replace what, you will see initially uni characters were used. I've stopped using uni characters as I'm not sure which ones nobody wants to ever use.

I am not sure either, but being French I would say that in roman, german and scandinavian languages at least the following characters are used:

All accented letters such as à, é, è , ë, ê, î, ï, ô, ü (german umlaut), û, etc.
oe (called "e dans l'o) as in oeuf, oeuvre, etc.
ñ (spanish "nina"
ç French cédille

Also, typographic rules in French (not sure whether they follow these rules in Italy or Spain) say that the english quotes (as in "quote") should be replaced by the opening and closing angle brackets or "guillemets", with a non-breaking space between the bracket and the word, in order to avoid widow/orphan words (both the brackets and the word should be on the next line if there is not room enough for them on a given line).

I am not sure that replacing english quotes by guillemets is at all possible using BD...

Robert

JSWolf
02-23-2008, 10:59 PM
Robert, please read http://www.mobileread.com/forums/showthread.php?t=11649&page=2 and that might answer your question about guillements.

babyd
10-15-2008, 11:05 AM
I may be wrong, but seem to remember that earlier versions of book cleaner had a bug where 'oe' came out as an emdash. This was because the oe unicode character was used to substitute for emdashes at some stage in the cleaning process. When it came to the replacement stage odd things happened.

I have BD installed and BC 1.5 I run the emdash bit and it all converts great but I am getting the oe issue.........I have it set to german, what do I need to do? Hope you can help :)

Patricia
10-15-2008, 04:44 PM
Try setting it to German, then reinstalling the latest book cleaner files. (Just drag and drop them into the Book Cleaner directory.)
It's odd that you're still having this problem. It vanished for me at about Book cleaner 1.3.

JSWolf
10-15-2008, 05:42 PM
I need to update the Book Cleaner files to fix some more minor issues.

babyd
10-15-2008, 06:08 PM
Try setting it to German, then reinstalling the latest book cleaner files. (Just drag and drop them into the Book Cleaner directory.)
It's odd that you're still having this problem. It vanished for me at about Book cleaner 1.3.

Thanks for the replies. Patricia, I have tried what you suggested.... Its on German and I am using the BC 1.5 files.........I open BC, then enter the two commands for emdashes as per the wiki guide, then open my book. The emdashes work great but all words containing 'oe' get turned to emdashes too , eg: 'does' becomes 'd--s' (sorry can't do emdashes on here lol). Then I have to use find/replace and manually change every oe emdash back to an oe.

Can't see what Im doing wrong. I know this was an issue previously but also saw it was fixed in 1.5. Just wish I could get it to run without all oe going to emdash too, then it would be perfect.

JSWolf
10-16-2008, 09:10 AM
babyd, I'll be uploading 1.6 later today so wait and try that and see what happens.

babyd
10-16-2008, 09:34 AM
HI JSWolf

Great thanks !!

I have been playing around with BD and found that if I set it to English and then load the book it will add emdashes and keep 'oe' correctly, but then English causes other small quirks, when I set it to German (as this is the preferred one) it puts in emdashes on 'oe' as well. Just thought I tell you in case it sheds light on something :D

RWood
10-16-2008, 10:00 AM
Jon:

Since you keep improving the Book Cleaner files, could you make a note including the date when you post a new version? When did version 1.5 get posted?

babyd
10-20-2008, 03:51 AM
I have now tried loading books in other languages, all do the emdash and 'oe's too except English, but then I get other characters that don't work as English causes its own issues. I have no idea why mine is working differently to everyone else's.........I even removed it all and installed again, I am using the up to date files for it all, but it still does the same thing. very strange.

Any news on the new update Jon?

Patricia
10-20-2008, 05:03 PM
Just a thought, but when making an LRF book, be sure to click on:
Make books/Sony Reader, then select the 'options' tab and click on 'as it it' in the dashes option.

babyd
10-21-2008, 02:39 AM
Yep, done that too ;)

I'm really stumped why mine seems to be working opposite to all of yours LOL

For now I'm using German and then using find/replace to hunt for all the oe emdashes and changing them back. Using English causes way too many quirks that need correcting. Hunting out the oe emdashes is really tedious though.

JSWolf
10-28-2008, 10:53 AM
Jon:

Since you keep improving the Book Cleaner files, could you make a note including the date when you post a new version? When did version 1.5 get posted?
I'm going to sort out the book cleaner files today and post 1.6. 1.5 was posted on January 8, 2008.

JSWolf
10-28-2008, 11:01 AM
The Book Cleaner files are now up to 1.6.

They add in a fix for gun types because when you have something like .44 the space in front of the . in .44 gets stripped.

Patricia
10-28-2008, 12:47 PM
Thanks, Jon.

JSWolf
10-28-2008, 02:09 PM
Thanks, Jon.
Thread title needs changing.

Patricia
10-28-2008, 05:54 PM
Done.
I only wish that vvv, who developed the Book Designer program, was as punctilious as Jon about updating and improving it. Meanwhile the new Book Cleaner files are working extremely well on my latest book.

JSWolf
10-29-2008, 04:13 AM
I'm hoping that because this thread has been brought to the front, more people who use Book Designer will see this and download these Book Cleaner files.

But at least the 1.5 files were downloaded 795 times. At least I hope that is correct. This is not just for Sony Readers.

babyd
10-29-2008, 04:49 AM
Jon, you are a star !! All my emdash/oe woes have gone ! It all works beautifully now, after using your update.

thank you so much

:thanks:

JSWolf
10-29-2008, 04:56 AM
Jon, you are a star !! All my emdash/oe woes have gone ! It all works beautifully now, after using your update.

thank you so much

:thanks:
You are very welcome. I'm happy it's working for you. Dashes/emdashes are one of my pet peeves with books. If it wasn't for Book Cleaner, I would have bugged the author of BD to get that fixed.

Novasea
10-29-2008, 02:20 PM
Thank you

Roberts324
10-31-2008, 08:22 AM
You are very welcome. I'm happy it's working for you. Dashes/emdashes are one of my pet peeves with books. If it wasn't for Book Cleaner, I would have bugged the author of BD to get that fixed.

Unfortunately, version 1.6 (as well as 1.5, btw) is broken when your language is French - that's my case - and the "oe" symbol is found in a text (mostly in words like "oeuvre", "oeuf", "coeur" or "loess".

At the very least, this sign should be changed to "oe", which is acceptable in French typography and wouldn't shock a soul. What really happens is that the sign disappears altogether, leaving "uvre", "uf", "cur" or "lss", that are mostly unreadable. But the best solution would be to leave the original sign alone.

Here is the output Bookdesigner gave me on an example text I created for this:
---
Robert Soubie
Fichier de test pour Bookdesigner
Je suis à l'uvre, et je marche sur des ufs.
Cette phrase contient les mots «oeuvre» et «oeufs».
Tant que nous y sommes, occupons-nous
· des accents:
car pâtre là
me léger hère être
i
cor hôte
ubiquité où
· de la cédille
çà et là

This file was created with BookDesigner program
bookdesigner@the-ebook.org
31/10/2008
---
And here is the original (note that the Mobilread preview shows the "official oe sign" on one line (in French, we say "o, e dans l'o"), and "oe" with separate letters on the following line (words enclosed in quotes):
---
Robert Soubie
Fichier de test pour Bookdesigner


Je suis à l'œuvre, et je marche sur des œufs.
Cette phrase contient les mots «oeuvre» et «oeufs».
Tant que nous y sommes, occupons-nous
• des accents:
car pâtre là
me léger hère être
i
cor hôte
ubiquité où
• de la cédille
çà et là
---
:p Perhaps a version 1.7 can cure this?

Patricia
10-31-2008, 08:35 AM
I have noticed the problem with oeuvre, manoeuvre, coeur etc.
I always search for the 'oe' ligature and replace with the characters 'oe' in an early edit on the source text, before I put it into BD.

Roberts324
11-08-2008, 09:56 AM
I have noticed the problem with oeuvre, manoeuvre, coeur etc.
I always search for the 'oe' ligature and replace with the characters 'oe' in an early edit on the source text, before I put it into BD.

Not a good solution, if you'll pardon me. Ligatured oe is a French character in the same way the cedilla is, for instance, and should remain untouched anytime the French language is involved.

Patricia
11-08-2008, 10:32 AM
Not a good solution, if you'll pardon me. Ligatured oe is a French character in the same way the cedilla is, for instance, and should remain untouched anytime the French language is involved.

I agree. And if I could find some workaround that allowed the oe ligature then I'd be very pleased to use it.

In fact, Book Designer is very poor with French typography. It removes the spaces adjacent to many punctuation marks. Guillemets should have a space next to them. I now add a non-breaking space during the conversion.

HarryT
11-08-2008, 10:36 AM
I don't seem to have had any trouble with this, myself. A fair number of my books have used "oe", "ae", etc, ligatures, and they've all come out just fine in BD. I always use it with the language set to German.

Mind you, I generally paste content into BD rather than "load" it. I wonder if that bypasses the issue?

Patricia
11-08-2008, 10:38 AM
I don't seem to have had any trouble with this, myself. A fair number of my books have used "oe", "ae", etc, ligatures, and they've all come out just fine in BD. I always use it with the language set to German.

Mind you, I generally paste content into BD rather than "load" it. I wonder if that bypasses the issue?


I shall have to experiment with that, Harry. Thanks.

(It bypasses the Book Cleaner files completely, though.)

orwell2k
12-01-2008, 10:32 AM
Quick question - I have used Book Designer for some years, mainly to create FB2 eBooks for my Acer n10 PDA (using Haali reader) and now my BeBook. I have followed the settings described here (e.g. German language, etc.) and most things work well - accented characters are recognised, em-dashes are retained, quotes are done correctly, etc.

I have noticed one problem that does not seem to have been raised yet - any source eBooks with the ampersand symbol "&" do not retain that symbol. Instead, it gets replaced with the string "amp;" Any ideas on how to address this problem?

I suspect this may be an FB2 issue, but you never know. Thanks.

:help:

Gudy
12-03-2008, 02:45 PM
That is, to the best of my knowledge, a bug in the FB2 export module of Book Designer.

The way I work around this is to create the book as usual, then load the resulting FB2 file into VIM (or your editor of choice) and do a search&replace, being careful to add spaces around the & when needed (those get sometimes broken, too).

JSWolf
02-20-2009, 11:00 AM
I've replaced version 1.6 with version 1.7. 1.6 I just noticed had a few mistakes in it and I've fixed those. Also, I've been able to remove a few lines so it will run faster to do the same thing.

Please update your Book Cleaner files to the 1.7 version. Thanks.

Valloric
02-20-2009, 02:55 PM
I've replaced version 1.6 with version 1.7. 1.6 I just noticed had a few mistakes in it and I've fixed those.

Could you tell us what those mistakes were?

JSWolf
02-21-2009, 06:54 PM
Could you tell us what those mistakes were?
When you have the caliber of a gun, it got the period incorrect.

Without using Book Cleaner to fix things like that, your .44 magnum ends up as a 44 magnum. This is how BD does it without using Book Cleaner at all.

What I've optimized is replacing the period on load to something else and then back after load. That works. There were a few other lines that fixed things because of the period. But since the period is being changed before BD gets to mess with it, it's ok once the file is fully loaded.

Andybaby
02-21-2009, 09:31 PM
Hey JSwolf,

Book Designer usually keeps the section breaks in chapters(usually a double line break, authors use them to indicate a pasage of time, or the change of perpective, etc, etc). which in most books are just a double Return, is there anyway to have Book Cleaner make them do "*****" instead of just a Empty line? of can you think of another way to do it.

For the books i do, I have to Manually change all the section breaks to "*****" by using the element browser set to Empty Line, and User tag/text in the Stars, Very Manual and takes be over a half hour for some books, BD adds Epmty Lines before and after titles too which is why i cant just to it all.

Sparrow
02-22-2009, 03:00 PM
:o - please ignore this post.

Thank you.

Santa Fe Painter
06-15-2009, 11:58 AM
I am importing .rtf files with images into BD. When I install the Book Cleaner files v1.7, the em dashes are correctly retained, but my images are not included.

Any ideas what I might being doing incorrectly?

corroonb
08-07-2009, 01:25 PM
Thanks for the files at the start of this thread.

I was using the old ones that come with the update zip posted with Book Designer 4 in another thread and it was replacing some question-marks with dashes. I didn't realise it until I'd created about 20 books, all without question marks.

corroonb
08-12-2009, 05:31 PM
Is there any reason why BookCleaner wouldn't create em dashes when importing and reformating a LIT file? It works fine when importing and formatting other RTF files but I converted this LIT file to RTF and it still doesn't work. It replaces the em dashes with a single dash.

The reason I ask is that many LIT files have spaces between paragraphs and the only reasonable way of removing them is by reformating the file when importing.

It seems the only way to convert this file to RTF with the em dashes is to remove the lines with Gutenmark or Textify and then import it without reformating.

I managed to get it reformated by replacing the em dashes in the RTF with -- which BookCleaner converted back into em dashes.

Andybaby
08-13-2009, 05:22 AM
are you sure you have the preload book cleaner files active?

1.bcf should change an emdash(uni151) to uni(137) and then 2 should change it back to an emdash

Andybaby
08-13-2009, 05:26 AM
I am importing .rtf files with images into BD. When I install the Book Cleaner files v1.7, the em dashes are correctly retained, but my images are not included.

Any ideas what I might being doing incorrectly?

sometimes if the images have certain characters in it if you run a find replace (which is what book cleaner is) it can replace characters inside the link to the image file you need to edit the html to restore the links

Scullion
08-13-2009, 06:58 AM
I
In fact, Book Designer is very poor with French typography. It removes the spaces adjacent to many punctuation marks. Guillemets should have a space next to them. I now add a non-breaking space during the conversion.

Could you tell me how you do this, Patricia? Whenever I try to replace a space in the guillemets with a non-breaking space in MS Word it changes the guillemets to quotes for some infuriating reason and I can't prevent it nor recover it except through undo. I ended up removing the spaces altogether as the Sony reader often leaves them orphaned.

Jellby
08-13-2009, 07:10 AM
Try to disable auto-replace and other smart-ass features of Word.

Patricia
08-13-2009, 08:47 AM
Could you tell me how you do this, Patricia? Whenever I try to replace a space in the guillemets with a non-breaking space in MS Word it changes the guillemets to quotes for some infuriating reason and I can't prevent it nor recover it except through undo. I ended up removing the spaces altogether as the Sony reader often leaves them orphaned.

I disable autoreplace in Word.
In Book Designer I run a find and replace if it hasn't come out correctly. (I copy and paste a non-breaking space plus guillemet into the replace option.)
It helps to go to the View menu and check the "show nbsp" and "show inner nbsp" so that you can see the non-breaking spaces.

I hope this helps.

Scullion
08-13-2009, 08:56 AM
Thanks to you both, That fixed it. I have been using Word for so long I have gone soft in the head, I think - I had completely forgotten about autoreplace. Many thanks, now I can concentrate on finding all those lost ligatures, LOL

corroonb
09-12-2009, 10:49 AM
Do these BookCleaner files convert en dashes to em dashes?

JSWolf
09-13-2009, 07:36 AM
No, they don't deal with en dashes at all. Do en dashes need to be fixed so they stay en dashes?

Patricia
09-13-2009, 08:28 AM
I find that without Book Cleaner, endashes become hyphens. With Book Cleaner, they become emdashes.
I tend to replace endashes with @ or # in the source text, then do a find and replace after putting the text into Book Designer.

corroonb
09-13-2009, 08:51 AM
Patricia is correct. With your BookCleaner files, en dashes are converted to em dashes. I just do a replace all so it's really a minor issue except where both en dashes and em dashes are used.

HarryT
09-13-2009, 08:52 AM
Given the comparative rarity of the en-dash, it's generally easy to decide what to do with it on a case-by-case basis if one follow's Patricia's advice.

ahi
09-14-2009, 12:49 AM
Given the comparative rarity of the en-dash, it's generally easy to decide what to do with it on a case-by-case basis if one follow's Patricia's advice.

In English, perhaps. In Hungarian there should only be en-dashes.

- Ahi

orwell2k
09-14-2009, 05:21 AM
I am using Book Cleaner files v1.7, and I have two problems:

(1) Embedded images are not preserved - this problem has been mentioned earlier and is related to the replacement of symbols in the "characters" representing the enoded images, so not much can be done.

(2) All em-dashes are replaced as hyphens. Em-dashes are never preserved, and I thought that this was specifically something that book cleaner files were supposed to take care of. As em-dashes tend to be without spaces between the words they separate in ebooks (word1—word2) since they are replaced as hyphens I lose all em-dashes when I create a new book (usually FB2).

Unfortunately I have stopped using the Book Cleaner files because these problems are worse than the occaissional small errors the files do fix. I have resorted to manually cleaning up the source file prior to loading into book designer, primarily:

Replace all em-dashes with <space>—<space>, which then allows me to do a global search and replace in book designer to replace all <space>-<space> with <space>—<space> (because em-dashes become dashes on import - I could just go back to replacing the spaced dashes with em-dashes alone "—" but I prefer having spaced em-dashes for readability (although not perhaps "correct" formatting). In truth I create FB2 books using middle dashes (effectively en-dashes) so I like the spaced dashes for seperators in this case - em-dashes are just too large for my taste.

Of course, I then have to go and check manually for things like weapons calibres (.38, .45, etc.) as they tend to be without leading spaces. After FB2 creation I also have to do the ampersand check as these are incorrectly generated. First I open the FB2 file (XML) in a text editor then do a global search and replace in two stages:

Find (without quotes) " amp; " and Replace with " &amp; "
Find (without quotes) " amp;" and Replace with "&amp;"

The first case handles situations like "Henry & Co." by keeping spaces around the ampersand. Once these are fixed, the second case picks up all the other non-spaced ampersand instances (such as R&D).

Of course, perhaps I am using Book Designer incorrectly, although I seem to have all the usual settings in place (language = German, etc.). So perhaps the BC files can be tweaked, but I'm not sure how. Does anyone else have these problems? It seems the handling of em-dashes is OK for most people as there have been few complaints. Cheers!

Patricia
09-14-2009, 08:59 AM
Orwell, if your emdashes are replaced by hyphens, then it's not clear that you have installed Book Cleaner properly. One of its functions is to preserve emdashes.

orwell2k
09-15-2009, 05:37 AM
Orwell, if your emdashes are replaced by hyphens, then it's not clear that you have installed Book Cleaner properly. One of its functions is to preserve emdashes.

I know, that's why it's confusing. But I have followed the instructions, and they clearly work for other aspects.

I copy the files to the "Program Files > Book Designer > BookCleaner" folder (1.bcf, 2.bcf). Note that there are also 3 other files already there (MiddleDashes_after.bcf, MiddleDashes_before.bcf, RemoveRepeatedEmptyLines.bcf).

Then in Book Designer I go to "Tools > Book Cleaner" and then select 1.bcf in the "input file: before formatting" drop-down box, and 2.bcf in the "input file: after formatting" drop-down box. Then close the window.

I have checked regularly that the 1.bcf and 2.bcf files are still loaded as described above, and they always are. Should the "loaded book" section be marked as whole? I assume that is only if you want to manually trigger the clean-up again, and when the book is first loaded the cleaner files run?

Am I missing anything else? My language is selected as German, and I think I have fairly basic settings selected for the program overall - see the attached pics for screencaps of my settings and the Book Cleaner window.

I have noted in other posts that MS Office seems to have some effect omn Book Designer functions - is this also the case for Cleaner?

Thanks for any help. :chinscratch:

Patricia
09-15-2009, 08:22 AM
That all sounds perfectly correct, Orwell.
So, the next thing to ask is how you load your texts into Book Designer.
Book cleaner won't work if you are cutting and pasting.

I open BD then drag and drop the source text into the BD window. At the bottom of the window, there's a little commentary, where it tells you that it's finding paragrah ends, running book cleaner etc.
Do you get this?

orwell2k
09-15-2009, 08:55 AM
That all sounds perfectly correct, Orwell.
So, the next thing to ask is how you load your texts into Book Designer.
Book cleaner won't work if you are cutting and pasting.

I open BD then drag and drop the source text into the BD window. At the bottom of the window, there's a little commentary, where it tells you that it's finding paragrah ends, running book cleaner etc.
Do you get this?

I am almost always opening an HTML document in Book Designer (File > Open), sometimes a LIT, DOC/RTF or TXT file. But always via Open File not cut and paste. I also see the little "status" message saying "finding paragraphs ends" and so on.

Having wasted your time, I have now just run some further tests, and it seems I am getting em-dashes preserved in most documents I try. I don't know what happened, but I can only guess that I had one strangely formatted source document that meant I lost the em-dahses. I will keep an eye on how it performs with further documents. My apologies.

Of course, I still have the problem of losing images when the Book Cleaner files run on opening a new source file. This is quite troublesome, and I guess we are unlikely to get that issue fixed?

Thanks again for your help, and apologies for the false alarm. :o

Patricia
09-15-2009, 08:23 PM
No worries, Orwell.
I make sure that I have checked the "save pictures" options in Configuration/settings. Even so, I frequently have to add the pictures by hand later.

JSWolf
01-08-2010, 09:48 AM
In fixing the periods in front of things like .45 for a gun type, when the HTML specifies say filename.jpg, that .jpg got changed so Book Designer was unable to load in the graphics. But I've fixed things for ...

.jpg
.gif
.png
.tiff
.bmp

So when Book Cleaner changes .jpg, it will be changed back and then the HTML processed so the graphics can load.

Patricia
01-08-2010, 11:59 AM
Thanks, Jon.

(Jon's new files are attached to the very first post in this thread.)

orwell2k
01-08-2010, 06:27 PM
Well done!

I will give it a try, although I have now worked out a routine for doing manual find/replace for things like .45, etc. But it will be nice to have less steps to remember... :chinscratch:

JSWolf
01-08-2010, 08:45 PM
Well done!

I will give it a try, although I have now worked out a routine for doing manual find/replace for things like .45, etc. But it will be nice to have less steps to remember... :chinscratch:
You are very welcome. I was trying to figure out why the graphics loaded once and not the second time. The only thing I did was sort out Book Cleaner. Now that I've fixed the problem, things like .45 will be fine and graphics will load.

kazbates
01-16-2010, 10:04 AM
Jon, I want to thank you once again for all your work here and with Book Designer. I am having the best of luck using Book Designer to edit and create the final version of the books I'm scanning. It is very much a learning process, but your invaluable posts have made it a great deal less stressful. If I could, I would transfer all of my Karma to you, Patricia and HarryT!!

Patricia
01-16-2010, 06:07 PM
Jon, This latest version of Book Cleaner works like a charm, and the graphics appear as if by magic. Thank you very much for all your work on this.

PUPPYCARE
01-22-2010, 01:08 AM
Hi guys

I have read through most of this thread as well as the instruciton manual. You have done a great job. And Book Reader is a terrific help. Unfortunately I am missing something.

I have loaded and copied the updates etc but when I open Dook Designer Help main help I get it saying it's Book Designer 4.0 Beta, not even Book Designer 4.0. And a lot of things you mention I just don't get come up. I downloaded BD in early Jan 10 from the only link that worked for me. I have also downloaded and copied the 30/07/ 07 update file and copied it over the original Book Designer files.

I can't get Book Cleaner to come up and I don't have an "insert" button that shows anything but Bookmarks. When I open the Book Cleaner folder I can see the five items I should get, showing inside it.

Can anyone tell me were I have gone wrong? I am wondering now if my original BD file download may have problems.

I can make books with BD and they look OK in mobipocket, but I want em dashes to work OK as we use a lot of them as well as short dashes, and also want ellipses to work properly if possible. I haven't seen them mentioned here, but I may have missed that. Mine come out with the spaces removed.

angelad
01-25-2010, 01:22 PM
Oh this is interesting, I should have stopped by earlier by this thread.

Patricia
01-25-2010, 01:36 PM
Hi guys

I have read through most of this thread as well as the instruciton manual. You have done a great job. And Book Reader is a terrific help. Unfortunately I am missing something.

I have loaded and copied the updates etc but when I open Dook Designer Help main help I get it saying it's Book Designer 4.0 Beta, not even Book Designer 4.0. And a lot of things you mention I just don't get come up. I downloaded BD in early Jan 10 from the only link that worked for me. I have also downloaded and copied the 30/07/ 07 update file and copied it over the original Book Designer files.

I can't get Book Cleaner to come up and I don't have an "insert" button that shows anything but Bookmarks. When I open the Book Cleaner folder I can see the five items I should get, showing inside it.

Can anyone tell me were I have gone wrong? I am wondering now if my original BD file download may have problems.

I can make books with BD and they look OK in mobipocket, but I want em dashes to work OK as we use a lot of them as well as short dashes, and also want ellipses to work properly if possible. I haven't seen them mentioned here, but I may have missed that. Mine come out with the spaces removed.

It sounds as though you've not actually installed BD5.
Perhaps my Book Designer hints and tips here just might help:
http://www.mobileread.com/forums/showthread.php?t=36908
There is a section on how to tell which version you have got.

JSWolf
02-05-2010, 02:14 AM
It sounds as though you've not actually installed BD5.
Perhaps my Book Designer hints and tips here just might help:
http://www.mobileread.com/forums/showthread.php?t=36908
There is a section on how to tell which version you have got.

The problem is that if you install BD 4 and then upgrade it to the latest version, it doesn't work properly. The latest update assumes you've been updating all along. But if you go to the thread here on MR and grab the installer and the update it will work as I've put all the proper files in the update to go from any version to the latest.

http://www.mobileread.com/forums/showthread.php?t=11786

PUPPYCARE
02-12-2010, 03:19 AM
I have downloaded it all again. On a quick look its still not right but I will go through it properly when I get time this weekend.

If I still don't get it I will let you know, though if it's not right I am obviously missing something really basic.

Thanks for all your help and the guide Patricia has written. It's a hell of a lot of work.

Patricia
04-08-2010, 11:47 PM
I think that I may have found a bug in the latest version of Book Cleaner. It seems to add a space before some full stops. This happens after a place name.
So I've been getting sentences like:

"They arrived at New York ."
He was in Orange State ."

I'm certain that my input files have no spaces. But the books do have them. And I can only think that it's due to a BC bug.

darkangelthn
05-21-2010, 08:57 AM
i'm needing some help. i am trying to convert a .rb file using book designer. I imported the file but i get something that looks like this:

Rain pounded the windshield with ferocity, causing the windshield wipers to fly across the glass, etching a thick path in the cascading water. It was a humid, August evening and the monsoon storm was flexing it's muscles with heavy rain and wind. Twenty- six-year-old Rachel Owen cursed as she pulled her BMW into a scarce parking plac rythe caslo paothe cadasferss,h the witimeith hebright grn twnumbs tagaand noyg plremd. BM myr BMtarng ess.>Fe "Damin t." S witurn thoffhe wiennatand nead ch tharndedyr BMse follher paumbly la. "If hami the iflexight I' fiver enllhgivmonyself." S wid mexter actnty- indvmoninuteto flg cruheck th and wiothe caac nythe caorm wad mturn tha nm wal acthir- ininute drdvmo fle caairport,nto a sn ughr drdvmcausing thchel O muanxie- i a soa ItS wiunt Rafe Owr pabloodoundedg it'nyr BMteletesnd wieletncedwitelyaoriffhfrom grippg the wisteerg wathe Owwhile

I have the BD 5 with the latest book cleaner 1.8. Can some one help me?

JSWolf
05-21-2010, 02:40 PM
I think that I may have found a bug in the latest version of Book Cleaner. It seems to add a space before some full stops. This happens after a place name.
So I've been getting sentences like:

"They arrived at New York ."
He was in Orange State ."

I'm certain that my input files have no spaces. But the books do have them. And I can only think that it's due to a BC bug.

I've had a look at the BC definitions and I don't see any place that would cause a space to be added before a period.